Closed Bug 1237017 Opened 4 years ago Closed 3 years ago

Don't show the application update prompt if the user is watching video or fullscreen content

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 893505
Tracking Status
firefox46 --- affected

People

(Reporter: mossop, Unassigned)

References

Details

If the user is watching a video on netflix they really don't want an app update dialog to pop-up at the critical moment of their shows. We should defer the prompt when the user is watching some full-screen content or even just a long-running video in the page.
Note: I'd prefer to get rid of that UI in its entirety and there are bugs for doing this already. The new notification would display somewhere in the UI similar to the current badge and this would hopefully not require code to determine if there is a video playing.
Note: I am working with Bram to change the notification so we no longer open a window
This should be fixed by the new doorhanger notification implemented in bug 893505
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
You need to log in before you can comment on or make changes to this bug.