Review Telemetry JSM ping building functions for handling exceptions & other failures properly

RESOLVED DUPLICATE of bug 1125787

Status

()

Toolkit
Telemetry
P3
normal
RESOLVED DUPLICATE of bug 1125787
2 years ago
2 years ago

People

(Reporter: Dexter, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Whiteboard: [measurement:client])

(Reporter)

Description

2 years ago
We have several Telemetry JS modules and function that contribute to building a ping payload. We should make sure that we're handling exceptions and failures properly.

We should audit the functions and defensively handle possible failure scenarios.
(Reporter)

Updated

2 years ago
No longer blocks: 1196852
No longer depends on: 1177958
(Reporter)

Updated

2 years ago
Whiteboard: [unifiedTelemetry] [measurement:client] → [measurement:client]
Blocks: 1113691
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125787
(Reporter)

Updated

2 years ago
No longer blocks: 1113691
You need to log in before you can comment on or make changes to this bug.