If-Modified-Since prevents access to HP printers

RESOLVED DUPLICATE of bug 1236329

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1236329
2 years ago
2 years ago

People

(Reporter: Pierre Fortin, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160105030211

Steps to reproduce:

I lost web access to a remote printer a while back.  Accessing it started returning "You cannot use this function because it has been disabled. For more information, contact your network administrator or the person who set up the printer."  Today, while trying to access my own printer, I got the same error...  I knew there were no changes made to my printer, so now I was motivated to get to the bottom of this...


Actual results:

Tried accessing the printers with konqueror and SURPRISE, accessing both works just fine. Fired up wireshark and the only difference I see on the initial connection is the addition of this header:
  If-Modified-Since: Fri, 17 Apr 2015 12:09:24 GMT
Searched about:config; but didn't find any way to turn this off to check.

Assuming I'm correct in that this is the source of the problem accessing HP (other?) printers, should this header even appear on an initial connection?  Deleted cookies and that doesn't help.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236329
(Reporter)

Comment 2

2 years ago
Fixed here too.
You need to log in before you can comment on or make changes to this bug.