kCFErrorDomainCFNetwork is shown when pages try to unsuccessfully redirect to native application

VERIFIED FIXED in 1.4

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Bingqing Li, Assigned: st3fan)

Tracking

(Blocks: 1 bug, {reproducible})

unspecified
Other
iOS
reproducible

Firefox Tracking Flags

(fxios1.4+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8705031 [details]
screenshot

Firefox for iOS v1.4

Some webpage cannot be opened in Firefox. And here's the error message:
>The operation couldn't be completed.
>(kCFErrorDomainCFNetwork error 305.)
>CFErrorHTTPBadURL


This issue can be reproduced by open the following urls in Firefox:

https://ju.taobao.com/m/jusp/other/liangfan/mtp.htm?scm=2027.4.1.4&spm=a215s.7406091.specialcard1.4&locate=SpecialCard1-4

https://market.m.taobao.com/markets/quality/channel/index_v3?locate=widget-4&spm=a215s.7406091.1.widget-4&scm=2027.4.1.1200
(Reporter)

Comment 1

2 years ago
(In reply to Bingqing Li from comment #0)
> 
> This issue can be reproduced by open the following urls in Firefox:
> 
> https://ju.taobao.com/m/jusp/other/liangfan/mtp.htm?scm=2027.4.1.4&spm=a215s.
> 7406091.specialcard1.4&locate=SpecialCard1-4
> 
> https://market.m.taobao.com/markets/quality/channel/index_v3?locate=widget-
> 4&spm=a215s.7406091.1.widget-4&scm=2027.4.1.1200

Those webpages can be opened successfully in Safari and Chrome.
(Reporter)

Updated

2 years ago
Blocks: 1227832

Updated

2 years ago
tracking-fxios: --- → ?

Updated

2 years ago
Duplicate of this bug: 1237999
From bug 1237999

> This is reproducible every time. I've seen it for a while but due to vacation, been slow to report. 
> I type in "tripadvisor" in the URL bar, it autocompletes to www.tripadvisor.com and I press "Go". 
> It then goes to www.tripadvisor.com and loads their page for 1 sec then it goes to this strange error page.

Updated

2 years ago
Keywords: reproducible

Updated

2 years ago
See Also: → bug 1226644
(Assignee)

Updated

2 years ago
Summary: kCFErrorDomainCFNetwork error while browsing some webpages → kCFErrorDomainCFNetwork is shown when pages try to unsuccessfully redirect to native application
(Assignee)

Comment 4

2 years ago
Created attachment 8706043 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/1426

The problem is that we should not show this error page if an app tries to probe if a native application is installed from JavaScript. The error page would overwrite the actual page. This patch fixes that. It will report errors for every navigation action except 'Other', which means JavaScript-initiated.
(Assignee)

Updated

2 years ago
tracking-fxios: ? → 1.4+
(Assignee)

Updated

2 years ago
Assignee: nobody → sarentz
(Assignee)

Updated

2 years ago
Whiteboard: [needsuplift]
(Assignee)

Comment 5

2 years ago
Merged.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

2 years ago
https://github.com/mozilla/firefox-ios/commit/980aae03da35b818b766adb2ea9d423131befc13
v1.x 8aabc23
Whiteboard: [needsuplift]
Target Milestone: --- → 1.4
The links provided in comment #0 are loading without any errors on build 1404
Verifying as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.