Last Comment Bug 1237643 - Bottom Padding doesn't show in scroll-able elements
: Bottom Padding doesn't show in scroll-able elements
Status: RESOLVED DUPLICATE of bug 748518
: testcase-wanted
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 43 Branch
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 08:04 PST by Danny Vickers
Modified: 2016-01-07 11:05 PST (History)
3 users (show)
epinal99-bugzilla2: needinfo? (danny.vickers)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Danny Vickers 2016-01-07 08:04:29 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

I have created multiple elements, which make use of "overflow-y: auto" in order to add a scrollbar once the content becomes vertically larger than the container. I added bottom padding to this to make sure the content didn't touch an element which overlaps it since it has a fixed position.

I found this question on StackOverflow after searching around, with the exact same issue occurring in Firefox:

http://stackoverflow.com/questions/13471910/css-applying-padding-to-box-with-scroll-bottom-padding-doesnt-work

A user there claims to have reported it in November 2012, but the issue is still there for me.


Actual results:

My content still gets overlapped by the fixed element, because the padding doesn't get rendered to fill the extra height of that element.


Expected results:

The padding should have been rendered at the bottom of the scroll-able element, I'm assuming this may happen with top, left and right padding also (based on vertical or horizontal scrolling).
Comment 1 User image Loic 2016-01-07 08:35:53 PST
Could you attach a testcase (.html) to the bug report, please.
Comment 2 User image Alice0775 White 2016-01-07 09:29:16 PST
Seems duplication of Bug 748518
Comment 3 User image Boris Zbarsky [:bz] (still a bit busy) 2016-01-07 11:05:54 PST
Indeed.

*** This bug has been marked as a duplicate of bug 748518 ***

Note You need to log in before you can comment on or make changes to this bug.