browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js,browser_inspector_breadcrumbs.js,browser_markupview_anonymous_01.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)]

RESOLVED FIXED in Firefox 46

Status

defect
--
critical
RESOLVED FIXED
3 years ago
11 months ago

People

(Reporter: KWierso, Unassigned)

Tracking

({crash, intermittent-failure})

unspecified
Firefox 46
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Comment 1

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=6494625&repo=fx-team
Summary: Intermittent browser_inspector_search-02.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)] → Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)]
Reporter

Comment 2

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=6496740&repo=fx-team
Summary: Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)] → Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)]
Comment hidden (Intermittent Failures Robot)
Mhm, 15 failures already, all on fx-team.

It's time we stop just accepting that devtools tests all constantly fail and crash, and merging around every bit of bustage to them which is landed.

fx-team is closed, fix it or back it out.
Severity: normal → blocker
Nevermind, we're apparently so worn down by your tests constantly crashing and failing that we already just went ahead and merged the cause of this ridiculously frequent crash around.
Severity: blocker → normal
Summary: Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)] → Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js,browser_inspector_breadcrumbs.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)]
Summary: Intermittent browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js,browser_inspector_breadcrumbs.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)] → browser_inspector_search-02.js,browser_rules_add-property-and-reselect.js,browser_inspector_iframe-navigation.js,browser_inspector_breadcrumbs.js,browser_markupview_anonymous_01.js | application crashed [@ xpc::IsInContentXBLScope(JSObject *)]
Blocks: 1237883
Severity: normal → critical
Keywords: crash
Fixed by backing out the patch from bug 1157469.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1157469
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.