Intermittent e10s test_websocket.html | Test timed out.

RESOLVED FIXED in Firefox 47

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: KWierso, Assigned: baku)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
mozilla47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox47 fixed)

Details

Attachments

(5 attachments)

baku, any thoughts?
Flags: needinfo?(amarchesini)
Assignee

Comment 2

3 years ago
It happened just once. And that is a big test, maybe something else was slowing down the mochitests.
I want to see some of these before working on it.
Flags: needinfo?(amarchesini)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1237470
Intermittent failures on opt builds really can't be a duplicate of the bug which disabled the test on debug builds, and baku isn't likely to see any more of them if it's resolved as a duplicate, and thus hidden away in the junk suggestions.

https://treeherder.mozilla.org/logviewer.html#?job_id=3720144&repo=b2g-inbound

There, there's another.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Intermittent test_websocket.html | Test timed out. → Intermittent e10s test_websocket.html | Test timed out.
Version: 45 Branch → Trunk
Comment hidden (Intermittent Failures Robot)
Blocks: e10s-tests
tracking-e10s: --- → +
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Looks like OSX is also affected by this bug. Can we try giving this the rr chaos-mode treatment and see if anything turns up?
Flags: needinfo?(amarchesini)
Also leaks when it fails on OSX:
TEST-UNEXPECTED-FAIL | leakcheck | tab process: 6760 bytes leaked (ChannelEvent, ChannelEventQueue, ListenerAndContextContainer, LoadInfo, Mutex, ...)
See Also: → 1244558
See Also: → 1239237
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

3 years ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Assignee

Comment 15

3 years ago
Posted patch ws1.patchSplinter Review
The current test_websocket.html is very complex: it contains 47 tests, often running together. What I propose here is to split that test in multiple mochitests (10 tests per mochitest), using a promise chain to manage them.
Attachment #8726762 - Flags: review?(ehsan)
Assignee

Comment 16

3 years ago
Posted patch ws2.patchSplinter Review
Attachment #8726764 - Flags: review?(ehsan)
Assignee

Comment 17

3 years ago
Posted patch ws3.patchSplinter Review
Attachment #8726765 - Flags: review?(ehsan)
Assignee

Comment 18

3 years ago
Posted patch ws4.patchSplinter Review
Attachment #8726766 - Flags: review?(ehsan)
Assignee

Comment 19

3 years ago
Posted patch ws5.patchSplinter Review
Attachment #8726767 - Flags: review?(ehsan)
Attachment #8726762 - Flags: review?(ehsan) → review+
Attachment #8726764 - Flags: review?(ehsan) → review+
Attachment #8726765 - Flags: review?(ehsan) → review+
Attachment #8726766 - Flags: review?(ehsan) → review+
Attachment #8726767 - Flags: review?(ehsan) → review+
Comment on attachment 8726762 [details] [diff] [review]
ws1.patch

Review of attachment 8726762 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/test/websocket_helpers.js
@@ +33,5 @@
> +      ok(false, "onerror called on test " + e.target._testNumber + "!");
> +    }
> +
> +    ws.addEventListener("close", function(e) {
> +      ws._receivedCloseEvent = true;

Seems like this flag is not being used after your patches any more...
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.