Improve tooltips on Live Bookmarks and allow to copy the site URI

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: cyber.spamage, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20151221154602

Steps to reproduce:

Create a RSS Feed Livemark in your Bookmark Toolbar
Right Click the Livemark and Choose Properties
Open Bookmarks Library
Select the Livemark


Actual results:

Only the Name & Description fields are shown, with no way to identify the source of the RSS feed nor the source Website.

Issue exists in Fx40 Release through latest Fx46 nightly

I personally have some livemarks without any Name or Description fields filled for the purpose of saving space, and this evening I noticed one of them was failing to load but I couldn't remember which feed it was. I checked the properties, and the Feed or Site location fields were completely missing in Fx40-Fx46. I had to rollback my install to the Fx38.5 ESR to figure out which site those livemarks with no other identification belonged to.


Expected results:

Feed Location & Site Location fields are shown in addition to Name & Description.
(Reporter)

Updated

3 years ago
Component: Untriaged → Bookmarks & History
OS: Unspecified → Windows
Hardware: Unspecified → x86

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 1

3 years ago
https://hg.mozilla.org/mozilla-central/rev/d84b62b367b4#l7.27
Blocks: 951651
OS: Windows → All
Hardware: x86 → All
Version: Trunk → 40 Branch
in the rare case you need the rss feed address you can just copy the rss feed bookmark and past to a textfield or a txt file or any other text input.

I don't think we will reintroduce those fields.

Updated

3 years ago
Keywords: regression
(Reporter)

Comment 3

3 years ago
(In reply to Marco Bonardo [::mak] from comment #2)
> in the rare case you need the rss feed address you can just copy the rss
> feed bookmark and past to a textfield or a txt file or any other text input.
> 
> I don't think we will reintroduce those fields.

Copying does seem to work for Feed Location, but not for Site Location.

There is also some inconsistency here with tooltips. So if you do not desire to reintroduce those fields, I would ask that you instead fix the following issues. The part where you cannot copy the Site Location in the Tooltip from the Open Link, I would deem most important.

Current Behavior:

Livemark Folder
*No tooltip on hover
*Copy/Paste = Feed Location

Livemark Open Link
*Tooltip for Site Location on hover
*Copy/Paste = Feed Location

Click Livemark Open Link
*Attempts to load Site Location, but the url is not shown in Url Bar is the website is down or not responding.
(this is a general problem with bookmarks/links/redirects in general I believe, where the url being loaded is not visible in the URL bar until the website responds and actually begins to load, which can make it difficult figuring out which url is failing to load.)


Expected Behavior:

Livemark Folder
*Tooltip for RSS Location (?) on hover similar to regular bookmarks
*Copy/Paste = Feed Location

Livemark Open Link
*Tooltip for Site Location on hover
*Copy/Paste = Site Location

Click Livemark Open Link
*Site Location shown in Url Bar even if the website is down and cannot be loaded.


I still would prefer that the Site Location & Feed Location fields be made visible again, but if you add a way to easily copy the Site Location like is currently possible with the Feed Location, I can live with this.
(In reply to Alex Firestone from comment #3)
> Livemark Folder
> *Tooltip for RSS Location (?) on hover similar to regular bookmarks

I agree, I think the tooltip should show both feed an site uri.

> Livemark Open Link
> *Copy/Paste = Site Location

Yes, this may be interesting to do.
This has a workaround, that is to open the uri and copy from the urlbar (apart from the next bug you pointed at)

> Click Livemark Open Link
> *Site Location shown in Url Bar even if the website is down and cannot be
> loaded.

Not sure if this is possible cause I think it's how the urlbar always worked. But also looks like a minor detail compared to the other improvements.
Summary: Live Bookmark Feed Location & Site Location Properties Missing (Livemark) → Improve tooltips on Live Bookmarks and allow to copy the site URI

Updated

3 years ago
Priority: -- → P3

Comment 5

2 months ago
Wontfixing because live bookmarks are going away - See Bug 1477667.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.