Closed Bug 1237941 Opened 5 years ago Closed 5 years ago

Synced Tabs panel only shows up to 15 tabs from each remote device

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 47
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- verified

People

(Reporter: vasilica.mihasca, Assigned: markh)

References

Details

Attachments

(2 files)

Reproducible on: Firefox 46.0a1 and Firefox 45.0a2 across all platforms

STR
1.Use '-no-remote -p' to start Firefox with two separate profiles, A and B.
2.Login on both profiles with the same Firefox account.
3.On profile A, ensure that at least “Tabs” sync option is checked in about:preferences#sync 
4.Open around 20 tabs on profile A and go to Panel Menu -> Synced Tabs.
5.On profile B, having at least “Tabs” sync option checked, click on Panel Menu -> Synced Tabs.

ER
Maximum 15 tabs are displayed in Synced Tabs (profile B)and a number of hidden tabs appears at the bottom of the tabs list for each device separately.
See screenshot: http://i.imgur.com/B6QXhLk.jpg

AR
Only 15 tabs are displayed in the list and there is no specified how many are hidden.


Additional notes:
- Reproducible on: Firefox 46.0a1 (2016-01-07) and Firefox 45.0a2 (2016-01-07) using Windows 10 64-bit, Mac 10.10.5 and ubuntu 14.04 32-bit.
Flags: needinfo?(rfeeley)
Blocks: 1239084
Ryan, are you ok with showing all tabs, even if there are 100 or more?
Priority: -- → P1
Summary: The hidden tabs number is not specified in Synced Tabs panel → Synced Tabs panel only shows up to 15 tabs from each remote device
Ryan, it might be good to have a sanity limit (100, 500?) from each device. What are you thoughts?
What's a reasonable maximum for performance? 100? 15 seems too little. I think 50 would be enough that people wouldn't care, and by then we'll have sidebar to handle overflow.
Flags: needinfo?(rfeeley)
Flags: firefox-backlog+
Sorry to pile on you Gijs, but at least this one is trivial :)

-      const maxTabs = 15;
+      const maxTabs = 50;
Assignee: nobody → markh
Status: NEW → ASSIGNED
Attachment #8714223 - Flags: review?(gijskruitbosch+bugs)
Blocks: 1244622
Comment on attachment 8714223 [details] [diff] [review]
0007-Bug-1237941-change-the-limit-of-synced-tabs-shown-fr.patch

Review of attachment 8714223 [details] [diff] [review]:
-----------------------------------------------------------------

Did you test that this will show a scrollbar etc. if necessary, and not just make the panel menu too big? The styling of this thing with the <deck> is sufficiently different that I think you may need to do your own work for that. Assuming you verified that that works correctly, r=me (though that is a non-trivial "if" - please re-request review if we do need to tweak styling :-) )
Attachment #8714223 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs Kruitbosch from comment #5)
> Did you test that this will show a scrollbar etc. if necessary, and not just
> make the panel menu too big?

The panel stretches down to the end of the screen, but that's the same thing I see with history. Note that with the current limit of 15, there's still a reasonable chance we'll hit this same case.

FWIW, this is a script I use to test the various states - it should be run from a "browser" scratchpad in a profile that's *not* configured for Sync.
To be clear:

(In reply to Mark Hammond [:markh] from comment #6)
> The panel stretches down to the end of the screen
*and* shows a scrollbar
https://hg.mozilla.org/mozilla-central/rev/9bde110cd227
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Duplicate of this bug: 1270420
Flags: qe-verify+
Verified fixed on Windows 7 64bit, Mac OS X 10.9.5 and Ubuntu 13.10 32bit using Firefox 47 Beta 6 (buildID: 20160516123243): maximum 50 tabs are displayed in the list for each device and a scrollbar is shown.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.