http://www.24joursdeweb.fr/ is broken on Aurora 45

VERIFIED FIXED in Firefox 46

Status

()

Core
Layout
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: julienw, Assigned: mattwoodrow)

Tracking

({regression})

45 Branch
mozilla46
Unspecified
All
regression
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox44 unaffected, firefox45+ unaffected, firefox46+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
1. Go to http://www.24joursdeweb.fr/
2. hover on the article tiles with your mouse
=> observe it's not properly painted.
(Reporter)

Comment 1

2 years ago
Works in Nightly 46.
Tracking as it is an obvious and visual regression.
status-firefox45: --- → affected
status-firefox46: --- → unaffected
tracking-firefox45: --- → +
Keywords: regression

Updated

2 years ago
Keywords: regressionwindow-wanted
I found that disabling e10s makes this bug much easier to reproduce. It also reproduces on trunk that way.

Regression range: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ddd566eb39b7a39d0ff630343f179fedc8fcafd5&tochange=7e18014be68d9e13760b2814862745911caf49a5

Regression from bug 1168263. Probably a dupe of one of the other blockers hanging off it, but we can figure that out if/when one of them actually gets fixed.
Blocks: 1168263
status-firefox44: --- → unaffected
status-firefox46: unaffected → affected
tracking-firefox46: --- → ?
Flags: needinfo?(matt.woodrow)
Keywords: regressionwindow-wanted
Version: 44 Branch → 45 Branch
Also, I was only able to reproduce this on Linux. Windows 10 WFM regardless of whether e10s is enabled or disabled on both trunk and aurora.
(Assignee)

Comment 5

2 years ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> I found that disabling e10s makes this bug much easier to reproduce. It also
> reproduces on trunk that way.
> 
> Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=ddd566eb39b7a39d0ff630343f179fedc8fcafd5&tochange=7e18
> 014be68d9e13760b2814862745911caf49a5
> 
> Regression from bug 1168263. Probably a dupe of one of the other blockers
> hanging off it, but we can figure that out if/when one of them actually gets
> fixed.

Comment 2 suggests that this is already fixed in 46, is that what you're seeing?

I've just landed all the outstanding fixes I have, so hopefully this just needs an uplift to aurora.
Flags: needinfo?(matt.woodrow)
On Linux I was able to reproduce on trunk as well with e10s disabled. I can also confirm that current m-c tip still reproduces the issue, so I suspect that this isn't going to be fixed on Aurora by uplifting whatever patches have already landed.

Comment 7

2 years ago
I can still reproduce the problem on Windows Nightly46.0a1 if I disabled both HWA and e10s.

https://hg.mozilla.org/mozilla-central/rev/6020a4cb41a77a09484c24a5875bb221714c0e6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20160111030207

Updated

2 years ago
OS: Unspecified → All
(Assignee)

Comment 8

2 years ago
Ok, I can reproduce this in a local build with HWA disabled.
Assignee: nobody → matt.woodrow
(Assignee)

Comment 9

2 years ago
Created attachment 8706740 [details] [diff] [review]
Force perspective layers to be active
Attachment #8706740 - Flags: review?(tlee)

Updated

2 years ago
Attachment #8706740 - Flags: review?(tlee) → review+

Comment 10

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/bfc71c935138

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bfc71c935138
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Verified on trunk. Ready for an uplift request? Also, I'm wondering if we can land a test for this. We've had a lot of preserve-3d related regressions lately, which is concerning from a test coverage standpoint.
Status: RESOLVED → VERIFIED
status-firefox46: fixed → verified
Flags: needinfo?(matt.woodrow)
Flags: in-testsuite?
Tracking for 45+ this is a regression.
tracking-firefox46: ? → +
(Assignee)

Comment 14

2 years ago
We're probably going to be backing the regressing bug out of Aurora as part of the preserve-3d backouts, so I'll wait on requesting uplift.
Flags: needinfo?(matt.woodrow)
The change that caused this regression was backed out from Firefox 45. A current Developer Edition build should now work correctly, or you can wait until 45 goes to Beta some time next week.

https://hg.mozilla.org/releases/mozilla-aurora/rev/64ec448f156d
status-firefox45: affected → unaffected
(Reporter)

Comment 16

2 years ago
Confirmed from my side.

Thanks !
You need to log in before you can comment on or make changes to this bug.