Closed Bug 123813 Opened 20 years ago Closed 20 years ago

DOM Inspector hangs on resize

Categories

(Other Applications :: DOM Inspector, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 121583

People

(Reporter: flo, Assigned: hewitt)

Details

Attachments

(1 file)

When i use DOM inspector on a local webpage (external stylesheet linked into it,
just plain html with h1, p etc...) DOM Inspector hangs when i try to resize it
by dragging the lower right corner of the window. It only hangs when resizing
the window higher than ~900 pixels. If i alt-tab to another mozilla window, the
window size is reset and mozilla continues to work as normal.

using 0.9.8 on win2k
did some more research to isolate the problem...

DOM inspector hangs, if the "Object - CSS Style Rules" pane is visible on the
right and you resize the window so that the scrollbar would appear/dissapear.

attached a "minimal" testcase, although this is reproducible on every page. to
reproduce, load the page, start DOM inspector, select "Object - CSS Style rules"
on the right hand side and resize the window until scrollbars (would) appear. ->
mozilla hangs, but you can alt-tab to another window and it continues running.
Flo, does it sound like a dupe ? Does CPU hit 100% or do you get
an actual hang ?
Comment #0:
> If i alt-tab to another mozilla window, the window size is reset and mozilla 
> continues to work as normal.

Comment #2:
> resize the window until scrollbars (would) appear. -> mozilla hangs, but you
> can alt-tab to another window and it continues running.

Pretty sure that this is bug 121583.  That's a good description of what happens
there.  It's happening all over the place.  We'll just add inspector to the list
now.

*** This bug has been marked as a duplicate of 121583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.