Closed Bug 1238374 Opened 4 years ago Closed 4 years ago

Access key conflict for new IDLE checkbox in IMAP Server Settings

Categories

(MailNews Core :: Account Manager, defect, trivial)

defect
Not set
trivial

Tracking

(thunderbird45 fixed, thunderbird46 fixed, seamonkey2.42 fixed, seamonkey2.43 fixed)

RESOLVED FIXED
Thunderbird 46.0
Tracking Status
thunderbird45 --- fixed
thunderbird46 --- fixed
seamonkey2.42 --- fixed
seamonkey2.43 --- fixed

People

(Reporter: rsx11m.pub, Assigned: rsx11m.pub)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #449021 +++

Sorry for yet another follow-up bug to this (and I didn't notice it earlier).

The access key for the checkbox is 'A' which conflicts with "Account Actions" in Thunderbird and "Add Account" in SeaMonkey. Thus, depending on the focus, one or the other is chosen on Alt+A.

It appears that 'w' is still available in that pane for either application.
Attached patch Use 'w' insteadSplinter Review
Note that I didn't rev useIdleNotifications.accesskey as only en-US is affected.
No problem to do so if desired.
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
Attachment #8706134 - Flags: review?(iann_bugzilla)
Attachment #8706134 - Flags: review?(acelists)
Attachment #8706134 - Attachment description: bug1238374.patch → Use 'w' instead
Err, http://mxr.mozilla.org/comm-central/search?string=alwaysAuthenticate tells me that 'w' is also used for an NNTP-related string. However, only one or the other is not hidden in that pane, never both at the same time, thus it hopefully won't matter in practical terms.
Comment on attachment 8706134 [details] [diff] [review]
Use 'w' instead

Review of attachment 8706134 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, 'w' seems unique and does work in my tests. 'a' also works to focus the "account actions" (but the popup does not open which is already filed).
Attachment #8706134 - Flags: review?(acelists) → review+
Attachment #8706134 - Flags: review?(iann_bugzilla) → review+
Thanks for the reviews, push for comm-central please.
Keywords: checkin-needed
Comment on attachment 8706134 [details] [diff] [review]
Use 'w' instead

[Approval Request Comment]
Regression caused by (bug #): Bug 449021
User impact if declined: confusion about shared access key
Testing completed (on c-c, etc.): works on 45.0a2 builds
Risk to taking this patch (and alternatives if risky): very low
Attachment #8706134 - Flags: approval-comm-aurora?
Comment on attachment 8706134 [details] [diff] [review]
Use 'w' instead

This patch has changes in localization files, which are too late for aurora. I am not convinced this issue is important enough to request late l10n.

Can this be done without changing l10n? If so, can you prepare a TB45 version of the patch?
Attachment #8706134 - Flags: approval-comm-aurora? → approval-comm-aurora-
Isn't this comparable to code changes as it doesn't just changes the l10n value, not the key?
I think this kind of change is fine, as the localizers have already used a different key anyway. The key is only changing of en-US. So they do not need to be made aware of this change (that's why the string id does not change).
Yes. And since keys didn't change it should be upliftable
Comment on attachment 8706134 [details] [diff] [review]
Use 'w' instead

OK that's fine then.
Attachment #8706134 - Flags: approval-comm-aurora- → approval-comm-aurora+
https://hg.mozilla.org/comm-central/rev/21ee57c22c62db0f2c61d15b60933ad563caf4d3
Bug 1238374 - Access key conflict for new IDLE checkbox in IMAP Server Settings. r=aceman,IanN a=IanN SM CLOSED TREE
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
Yes, there are precedence cases for en-US changes of accesskeys only.
I didn't ref the entity on purpose for that reason (thus no l01n impact).

Push for comm-aurora as well then, please.
Keywords: checkin-needed
Whiteboard: [c-n: comm-aurora]
You need to log in before you can comment on or make changes to this bug.