Firefox silently aborts request after ~10 seconds with status 0

RESOLVED DUPLICATE of bug 1235509

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1235509
2 years ago
2 years ago

People

(Reporter: John Leach, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8706138 [details]
HAR export of request

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160109065441

Steps to reproduce:

I'm clicking a link on a page. I'm running Firefox on Ubuntu Wily.


Actual results:

After ~10 seconds of the spinner, the request is silently aborted. The original page stays displayed, no error message of any kind is shown.

The firefox network inspector shows a GET request being made but with an empty response and a status icon of a grey circle (a status of 0 according to the HAR). I've attached the HAR output, but I've changed the request domains to example.com - everything else is left unmodified.

The web server logs the request as successful (HTTP 200) but several seconds after firefox has aborted it.

If the server renders the page in less than about 10 seconds, the page is loaded successfully by Firefox.

Other requests to parts of the the same web application have the same problem, including POST requests. Anything taking longer than about 10 seconds is affected. Other pages load fine.

I've also tried this with Firefox v44 and it's broken there too.

Copying the request in curl format from the inspector and running the curl command succeeds.

Making the same request using Google Chrome 47 from the same machine is also successful - Chrome will wait as long as necessary and complete the request.

I've also tested it over an ssh tunnel to a http port on the server, to rule out a tls problem or a networking problem. Using wireshark, I can see the request take some seconds and then firefox sending a FIN/ACK packet


Expected results:

The link should be following and the new page should be loaded, or if this is an error with the server, an error should be displayed.
(Reporter)

Comment 1

2 years ago
Created attachment 8706139 [details]
output from tshark for aborted request
(Reporter)

Comment 2

2 years ago
I've reproduced more simply. Use netcat to listen on a local port:

nc -l -p 8010

then try access that port using firefox. Firefox connects, sends it's request and then after about 10 seconds, firefox closes the connection.

Google chrome will sit waiting much longer (apparently indefinitely).

Also just tried with a brand new firefox v44 profile in safe mode to rule out any weird configuration I might have made. Problem still persists.

I'm using firefox v44 from the mozillateam/firefox-next package repository.

And firefox v46 from the ubuntu-mozilla-daily package repository.
(Reporter)

Comment 3

2 years ago
This problem occurs with Firefox 43.0.4 too.

This problem is NOT occurring with Firefox 41.0.2. That seems to wait indefinitely like Chrome.

Updated

2 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
this is dup of bug 1235509.

To test it, can you just change pref network.notify.changed to false ( in a tab enter about:config) and then it should work normally?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235509
There is going to a real fix for the problem, not just turning the network change events off, in nightly soon. in next 1-2 days.
(Reporter)

Comment 7

2 years ago
Setting pref network.notify.changed to false does indeed fix this, and I do have a local ipv6 gateway sending router advertisements, and I can see with wireshark that they correlate with firefox closing connections!

Thanks Dragana - nicely spotted!
You need to log in before you can comment on or make changes to this bug.