cert error page: reason explained for weak ciphers, but next sentences says for some reason

RESOLVED DUPLICATE of bug 1238382

Status

()

--
minor
RESOLVED DUPLICATE of bug 1238382
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected, fennec45+)

Details

Firefox 46.0a1 + 45.0a2 20160110 on Android 4.1.2

1. Visit https://badssl.com/
2. Select the test page for RC4.

Actual result:
Cert error page explains why it has blocked the connection and says in the next sentence that the page can't be loaded for some reason.

Expected result:
Second sentence gets removed.
This also sounds like a regression from bug 1238382.
Blocks: 1238382
Flags: needinfo?(past)
Flags: needinfo?(jmoradi)

Updated

3 years ago
tracking-fennec: --- → ?
If Fennec is anything like desktop, then this is more likely to be fallout from bug 1207137. I'll look further once I'm done with bug 1238382.
Flags: needinfo?(past)
I fixed the problem reported in comment 0 in bug 1238382. Indeed it was caused by the changes in bug 1207137 that have disabled RC4 by default. However, bug 1220321 still remains unfixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jmoradi)
Resolution: --- → DUPLICATE
Duplicate of bug: 1238382

Updated

3 years ago
tracking-fennec: ? → 45+
You need to log in before you can comment on or make changes to this bug.