Closed Bug 1238771 Opened 6 years ago Closed 6 years ago

Large webappsstore.sqlite will heavily affect the responsiveness of Firefox's UI

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 742822

People

(Reporter: human.peng, Unassigned)

Details

Attachments

(1 file)

6.38 MB, application/octet-stream
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2612.0 Safari/537.36

Steps to reproduce:

When webappsstore.sqlite file is very large, it heavily affect the responsiveness of UI.

The user (me) who has a 45MB webappsstore.sqlite with about 6000 rows from YouTube and 7500 rows from Google experiences huge responsiveness problem on complex websites like youtube.com, maps.google.com

Also check: https://www.reddit.com/r/firefox/comments/40gbos/psa_large_webappsstoresqlite_file_in_your_profile/
I mad a video to clearly show the problem. Please watch it in 1080p60.

https://youtu.be/BZQ7Va3gAdE (it takes a while to process)

It's worth note the responsiveness is improved when I test on Nightly. It's partially due to asynchronous scrolling. If I turn it off, it sill feels laggy compared to brand new profile.
Attached file webappsstore.7z
I deleted all entries but Youtube.com's for you guys to test (surprisingly, it's file size is about the same?)
Flags: needinfo?(amarchesini)
> I deleted all entries but Youtube.com's for you guys to test (surprisingly,
> it's file size is about the same?)

2 things about this bug:

1. I'm working on splitting the localstorage file in several dbs. one per origin, managed by quotaManager: bug 742822
2. the size stays the same: you must execute a 'vacuum' if you want to reduce the size. We don't do it when we delete records because 'vacuum' is expensive operation from a I/O point of view.

I mark this bug as duplicate for bug 742822 because fixing that bug, we fix this too.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 742822
Another indication that the split is the right thing to do.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.