Loading a page with an anchor sometimes does not go to this anchor

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: julienw, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:
1. Load up http://fantasai.inkedblade.net/style/design/w3c-restyle/2016/sample#obsolete
=> see you're not at the "2.3.5 Annoying Spec Obsoletion Warning Boxes" part in the page.
=> KO
2. click on the URL, press enter again
=> now you're at the correct location.

This is painful because this means some anchored URLs just don't work as expected.
(Reporter)

Comment 1

2 years ago
Tested on Aurora 45 (build id: 20160104004010)
(Reporter)

Comment 2

2 years ago
Fails also in Nightly 46 (build id: 20160111030207)

You can try pressing F5, we can see the page is going up of a fixed amount each time you press F5.
I think this is a duplicate of a very old bug.
(Reporter)

Comment 4

2 years ago
I've found very old bugs that were all fixed. I wonder if the issue is not different here; especially the fact that F5 moves up in the page is strange. Maybe some specific page layout triggers this.
The page performs an explicit scroll as part of its scripts (trying to adjust for DOM changes it's making), and it does it wrong in some cases as far as I can see...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.