Closed Bug 1238955 Opened 4 years ago Closed 3 years ago

The light themes are not synced

Categories

(Firefox :: Sync, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1287748
Tracking Status
firefox46 --- affected
firefox49 --- affected
firefox50 --- affected
firefox51 --- unaffected
firefox52 --- unaffected

People

(Reporter: mboldan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fixed by bug 1287748])

Reproducible on Firefox 46.0a1 (2016-01-11) and Firefox 44.0b8(20160111185352) under Mac OS x 10.8.5, Ubuntu 12.04 x86 and Windows 10 x64

Steps to reproduce:
1. Start two separate profiles (A & B) on the same machine.
2. Log in on both profiles with the same user.
3. On profile A, go to about:addons and install a light theme (e.g. https://addons.mozilla.org/en-US/firefox/addon/kitty-bad-hair-day/).
4. Perform a Sync on profile A.
5. Perform a Sync on profile B.
6. On profile B, disable the light theme from about:addons -> Appearance.
7. Perform a Sync on profile B.
8. Perform a Sync on profile A.

Expected:
The profiles are synced and the light theme is disabled from profile A.

Actual:
The light theme is not disabled from profile A.

Additional notes:
Intermittent - After refreshing the profile A (F5), the light theme appears disabled in about:addons -> Appearance, while the theme is still enabled.
This issue is also reproducible on FF 35.0a1 (2014-10-01). I will continue with the investigations as soon as possible in order to see if this is a regression, or not.
Flags: firefox-backlog+
Priority: -- → P3
Blocks: syncmore
Flags: firefox-backlog+
Priority: P3 → P2
This works for me.  Are you still having this issue?
Flags: needinfo?(mihai.boldan)
FWIW, it's possible this was fixed by bug 1287748 (assuming we sync the themes themselves, which I didn't think we did, but am likely wrong about) - that bug fixed an issue with how the themes are *selected* by sync rather than impacting how they actually sync.
The issue is still reproducible on Firefox 49.0.1 and on Firefox 50.0b6.
On Firefox 51.0a2 (2016-10-11) and on Firefox 52.0a1 (2016-10-11), the issue is not reproducible.

The tests were performed under Windows 10x64, Mac OS X 10.11.6 and under Ubuntu 16.04 x64.

Mark, do you think we should mark this resolved fixed based on your assumption (Comment 3)?
Flags: needinfo?(mihai.boldan) → needinfo?(markh)
Whiteboard: [fixed by bug 1287748]
(In reply to Mihai Boldan, QA [:mboldan] from comment #4)
> Mark, do you think we should mark this resolved fixed based on your
> assumption (Comment 3)?

Versions match, so sounds legit! Thanks.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(markh)
Resolution: --- → DUPLICATE
Duplicate of bug: 1287748
You need to log in before you can comment on or make changes to this bug.