If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

GEOLOCATION - Unknown error acquiring position - OSX Permissions Issue

RESOLVED DUPLICATE of bug 1232995

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1232995
2 years ago
2 years ago

People

(Reporter: edwardhowl, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.73 Safari/537.36

Steps to reproduce:

I have users on OSX reporting a location issue in Firefox. I have verified it. Firefox (current download as of 1/11/15) on OSX El Capitan. On a website that uses location services, click allow. 


Actual results:

If you check the error callback you get error code 2: Unknown error acquiring position.


Expected results:

In Safari it requests this permission in the browser then you receive another prompt (from OSX) to allow Safari to access location. I do believe that Firefox is not requesting this permission from the operating system which is why it is failing to acquire location. There is no way in OSX to enable location services for all applications and no way to add an application manually.

https://support.apple.com/en-us/HT204690

Comment 1

2 years ago
I guess.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → General
Resolution: --- → DUPLICATE
Duplicate of bug: 1232995
You need to log in before you can comment on or make changes to this bug.