font wrong in several places

VERIFIED DUPLICATE of bug 991

Status

()

Core
HTML: Parser
P2
normal
VERIFIED DUPLICATE of bug 991
19 years ago
19 years ago

People

(Reporter: buster, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
could be style or parser bug.
"FBI warns" header font too big.  Other similar headers have same problem.
"NBA lockout" too big, and all headers below it in that column.  Headers before
it in that column are fine.

Updated

19 years ago
Assignee: peterl → rickg
Component: Style System → Parser

Comment 1

19 years ago
This is the parser dealing with badly mangled source HTML.
Here's a reduced version of the problem:
<CENTER>
  </FONT>
  <FONT face=arial,helvetica size=1>
    Centered arial size=1 [BREAK]
  </CENTER>
</FONT>
</FONT>

<FONT face=arial,helvetica size=1>
  <B>
    <FONT size=2>Bold Arial font size=2</B>
  </FONT>
  <P>
    <FONT color=maroon>Maroon Arial font size=1</FONT>
    <BR>
    <FONT size=2>
      <B>Bold Arial font size=2</B>
    </FONT>
    [ Arial font size=1 ]
    <BR clear=all>
    <FONT size=-2>
      <CENTER>Centered Arial size=1
  <P>
    <CENTER>Centered Arial size=1
  <P>
    <FONT size=-1>
      <B>Bold Arial size=2
        <BR>
      </FONT>
    </B>
    Centered Arial size=1
  </P>
</CENTER>
</CENTER>
</FONT>
</FONT>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
Setting all current Open/Normal to M4.

Comment 3

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Comment 4

19 years ago
*** Bug 5550 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: 3847 → 4141
(Assignee)

Updated

19 years ago
Assignee: rickg → peterl
Status: ASSIGNED → NEW
(Assignee)

Comment 5

19 years ago
I think this is yours now.

Updated

19 years ago
Assignee: peterl → rickg

Comment 6

19 years ago
Nope. There are still parser DTD issues. This is a lack of style tag
propogation.

Specifically, in the recuced sample: The second <FONT face=arial,helvetica
size=1> isn't propogating into the following <P> tag.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6 → M7
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 991 ***

Comment 8

19 years ago
Attempting to steal gem's HTMLParser bugs all at once.  Changing QAContact to
janc.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
verified
You need to log in before you can comment on or make changes to this bug.