Get Next 500 news messages shouldn't be displayed when server selected.

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Rob Wilcox, Assigned: Stefan Borggraefe)

Tracking

({verified1.7})

Trunk
verified1.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

With the newsgroup server selected, the File->Get next 500 news message option
is available, but doesn't do anything.

I figure that this shouldn't be displayed at this point.. It should only be
displayed when an actual newsgroup is selected.

Reproducible: Always
Steps to Reproduce:
1. Open Mail & Newsgroups.
2. Click the newsgroup server at the top of left of the window
3. Click the File menu, you will then see the  menu item displayed.

Actual Results:  The menu item "Get next 500 news messages" is displayed, but
doesn't do anything.

Expected Results:  Maybe it shouldn't be displayed at this time?

Comment 1

17 years ago
you mean it should not be enabled? Again, a front end issue...
Status: UNCONFIRMED → NEW
Component: Offline → Mail Window Front End
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
That's right.  I don't think it should be displayed, because clicking it doesn't
appear to do anything at all.
Thx Rob

Comment 3

17 years ago
adding stephend
Rob, Gary; this seems to be a DUP of bug 113414.  Please mark it if you agree,
and I'll verify.
(Reporter)

Comment 5

17 years ago
No, I don't think it is the same.  What I'm saying is that when you click on the
newsgroup server at the top of the list of newsgroups, then the menu item is
still available.  Is it supposed to be?  When I clicked it, it didn't do anything.
Thx Rob
Okay, server vs. newsgroup, my bad.  
Summary: Get Next 500 news messages displayed always → Get Next 500 news messages shouldn't be displayed when server selected.

Comment 7

17 years ago
fwiw, 4.x disables get next 500 mesgs when server is selected.
(Reporter)

Comment 8

17 years ago
Gary how do you mean 4.x ?

Comment 9

17 years ago
The old netscape communicator browser, currently at version 4.79.
(Reporter)

Comment 10

17 years ago
Okay, I see.  Then yes, it should not be dispayed as per Communicator  - at
least that's what I think.
Should be Seth's, but maybe Sean Su should help?
Assignee: bienvenu → sspitzer
s/should/could, *really* (not a slip of tongue, fingers, rather).
(Assignee)

Comment 13

14 years ago
I have a patch for this.
Assignee: sspitzer → Stefan.Borggraefe
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 14

14 years ago
Created attachment 145633 [details] [diff] [review]
Patch

Fixes both TB and Seamonkey. This also removes an "else after return" in the
function I touched.
(Assignee)

Updated

14 years ago
Attachment #145633 - Flags: review?(bienvenu)

Updated

14 years ago
Attachment #145633 - Flags: review?(bienvenu) → review+
(Assignee)

Updated

14 years ago
Attachment #145633 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #145633 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 15

14 years ago
Comment on attachment 145633 [details] [diff] [review]
Patch

Fairly low-risk patch to fix UI nit.
Attachment #145633 - Flags: approval1.7?
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 16

14 years ago
Comment on attachment 145633 [details] [diff] [review]
Patch

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #145633 - Flags: approval1.7? → approval1.7+
(Assignee)

Updated

14 years ago
Keywords: fixed1.7

Comment 17

14 years ago
Verified as fix on latest 1.7 branch 06-24 build.
Changing keywords from fixed1.7 to verified1.7.
Leave this bug status "as is" until this bug be verified on trunk again...
Keywords: fixed1.7 → verified1.7
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.