Users are unable to scroll articles on yahoo.com in browser

VERIFIED DUPLICATE of bug 1236979

Status

()

defect
VERIFIED DUPLICATE of bug 1236979
4 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][dogfood-blocker], )

Attachments

(1 attachment)

Posted file logcat
Description:
On yahoo.com when reading an article the user is unable to scroll down in the article to read it.

Repro Steps:
1) Update a Aries to 20160112105459
2) Open Browser
3) Navigate to an article on yahoo.com
4) Attempt to scroll the article
5) Observe screen

Actual:
Users are unable to scroll articles and read them all

Expected:
It is expected that users are able to scroll articles on yahoo

Environmental Variables:
Device: Aries 2.6
Build ID: 20160112105459
Gaia: 3c97d6a8ac5a69662e1e2c22a84ea59bf50c305e
Gecko: e790bba372f14241addda469a4bdb7ab00786ab3
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/7ntMYWGx1fk), logcat
This issue DOES occur on Flame 2.6.

Environmental Variables:
Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20160112030203
Gaia: 3c97d6a8ac5a69662e1e2c22a84ea59bf50c305e
Gecko: e790bba372f14241addda469a4bdb7ab00786ab3
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D v4
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Result:
Users are unable to scroll articles and read them all
===========================================
This issue DOES NOT occur on Aries 2.5.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
BuildID: 20160112204147
Gaia: 1dec9c2fba119aabcc82c95225dbef24de148323
Gecko: f8aeb8408f1132279333f590a6ccf837c1a001b5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
Users are able to scroll articles.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
kats, any idea whats going on here?
Flags: needinfo?(bugmail.mozilla)
Not offhand, no. Regression window would be useful.
Flags: needinfo?(bugmail.mozilla)
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][dogfood-blocker]
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qaurgent
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Build ID               20151231113338
Gaia Revision          9f665863ea9c3dd9585905ef002e8fa06713d820
Gaia Date              2015-12-30 20:17:19
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/31edd1840c5f651b5dbf182fdb7f04fe98c88d86
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20160104.185047
Firmware Date          Mon Jan  4 18:51:01 EST 2016
Firmware Version        V18D V4
Bootloader             L1TC000118D0

First Broken Environment Variables:
Build ID               20151231115040
Gaia Revision          9f665863ea9c3dd9585905ef002e8fa06713d820
Gaia Date              2015-12-30 20:17:19
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/9fbf850dc78d7197132a298f9ec0270c7de16a13
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20160104.185047
Firmware Date          Mon Jan  4 18:51:01 EST 2016
Firmware Version        V18D V4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko – issue DOES NOT repro
Gaia Revision          9f665863ea9c3dd9585905ef002e8fa06713d820
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/31edd1840c5f651b5dbf182fdb7f04fe98c88d86

First Broken Gecko & Last Working Gaia – issue DOES repro
Gaia Revision          9f665863ea9c3dd9585905ef002e8fa06713d820
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/9fbf850dc78d7197132a298f9ec0270c7de16a13

Gaia pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=31edd1840c5f651b5dbf182fdb7f04fe98c88d86&tochange=9fbf850dc78d7197132a298f9ec0270c7de16a13

Possibly caused by bug 1213126
QA Whiteboard: [MGSEI-Triage+]
That sounds plausible. dholbert, is there a way to disable WebKit prefix support on specific sites?
Flags: needinfo?(dholbert)
No, there isn't a way to do that. (But users can disable the pref as a local workaround.)

I'll take a closer look when I get into the office; I'm able to reproduce locally on my android phone, and I can confirm that the pref-flip makes the problem go away. Sample article which triggers the bug:
 https://www.yahoo.com/news/least-one-jackpot-winner-1-6-billion-us-045419565.html
Component: Gaia::Browser → CSS Parsing and Computation
OS: Gonk (Firefox OS) → All
Product: Firefox OS → Core
Hardware: ARM → All
Version: unspecified → Trunk
Blocks: 1213126
Flags: needinfo?(dholbert)
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][Severe]
QA Whiteboard: [MGSEI-Triage+][Severe] → [MGSEI-Triage+][severe]
Interesting, not able to reproduce here on a Nexus 6P. Will try on some other phones.
OK, to reproduce you need to start at www.yahoo.com, then click on any article. Direct page loads don't end up with the bug -- it appears they're pushState'ing the URL and transitioning in the content after clicking an article title.

(I notice a nice css transition in Chrome, but not in Fennec, probably due to the following (old? custom?) Modernizr test:

g.csstransforms3d = function() {
  var e = !!D("perspective");
    return e && "webkitPerspective" in o.style && x("@media (transform-3d),(-webkit-transform-3d){#modernizr{left:9px;position:absolute;height:3px;}}", function(t, n) {
    e = t.offsetLeft === 9 && t.offsetHeight === 3
  }), e
}

That's why we end up with a "stencil-no-csstransforms3d" class on the documentElement.
Hi Adam, please leave youtube videos as comments -- the URL field is intended for URLs to pages with bugs. Thanks!
OK, I fairly certain this comes down to not firing webkitAnimationEnd events. In the setupEvents method of (incoming massive URL)

https://s.yimg.com/zz/combo?os/mit/td/highlander-client-0.0.314/highlander-client-lang-strings_en-us/highlander-client-lang-strings_en-us-min.js&os/mit/td/ape-af-0.0.324/af-content/af-content-min.js&os/mit/td/ape-af-0.0.324/af-dwelltime/af-dwelltime-min.js&os/mit/td/highlander-client-0.0.314/highlander-content/highlander-content-min.js&os/mit/td/ape-af-0.0.324/media-agof-tracking/media-agof-tracking-min.js&os/mit/td/ape-af-0.0.324/af-eu-tracking/af-eu-tracking-min.js&os/mit/td/highlander-client-0.0.314/highlander-tracking/highlander-tracking-min.js&os/mit/td/highlander-client-0.0.314/highlander-routes/highlander-routes-min.js&os/mit/td/stencil-3.1.0/stencil-imageloader/stencil-imageloader-min.js&os/mit/td/dust-helpers-0.0.144/intl-messageformat/intl-messageformat-min.js&os/mit/td/dust-helpers-0.0.144/dust-helper-intl/dust-helper-intl-min.js&os/mit/td/dust-helpers-0.0.144/intl-helper/intl-helper-min.js&os/mit/td/highlander-client-0.0.314/highlander-viewer/highlander-viewer-min.js&/nn/lib/metro/g/myy/myy_viewer_0.0.9.js&yui:3.12.0/yql/yql-min.js&/nn/lib/metro/g/myyheader/uh_init_0.0.12.js&os/mit/td/ape-applet-0.0.207/ape-applet-lang-strings_en-us/ape-applet-lang-strings_en-us-min.js&os/mit/td/angus-0.0.26/angus-slider/angus-slider-min.js&os/mit/td/stencil-3.1.0/hammer/hammer-min.js&os/mit/td/stencil-3.1.0/stencil-slider/stencil-slider-min.js&yui:3.12.0/yql-jsonp/yql-jsonp-min.js:

setupEvents: function() {
...
  t.viewerWrapper && (t.viewerWrapper.addEventListener(b, t.onAnimationEnd.bind(t))
...
}


b comes from:

b = function() {
  var e = a.createElement("div"), t, n = {
    mozAnimation: "animationend",
    oAnimation: "oanimationend",
    webkitAnimation: "webkitAnimationEnd",
    animation: "animationend"
  };
  for (t in n)
    if (n.hasOwnProperty(t) && e.style[t] !== undefined)
      return n[t];
  return null 
}(), which evaluates to webkitAnimationEnd (because they test for prefixed before unprefixed).
Depends on: 1236979
Awesome, thanks Mike! I'll hopefully have a patch for that bug in the next day or two, and we can see if it helps with this bug.
blocking-b2g: 2.6? → 2.6+
I verified that my patches for bug 1236979 do indeed fix this bug, btw (using this preliminary Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a5cd3ff85969 )

I should have that bug's patches up for review tomorrow - sorry for the wait here.
This is fixed in today's Fennec Nightly. Can you verify Adam?
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(aalldredge)
Resolution: --- → FIXED
This issue is verified fixed on Aries 2.6 and Flame 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20160203105933
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: f2f8fc172f4c62334e9a92bcf10e00fe877387d5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20160203030235
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: f2f8fc172f4c62334e9a92bcf10e00fe877387d5
Gonk: 8a066f7fa7410e32b58def35f322aa33f03db283
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Result:
The user can scroll through articles opened on the yahoo.com homepage.
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][severe] → [QAnalyst-Triage?][MGSEI-Triage+][severe]
Flags: needinfo?(aalldredge) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+][severe] → [QAnalyst-Triage+][MGSEI-Triage+][severe]
Flags: needinfo?(ktucker)
Thanks! Marking as a duplicate of bug 1236979 then. (and marking it verified based on comment 12, 13, 14.)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1236979
No longer depends on: 1236979
You need to log in before you can comment on or make changes to this bug.