Closed Bug 1239172 Opened 4 years ago Closed 4 years ago

DrawTarget alternates between Skia / CG even though pref is skia

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 942688

People

(Reporter: mchang, Assigned: mchang)

References

Details

(Whiteboard: [gfx-noted])

While trying to debug bug 1239152, I noticed that during the test, we initialize both DrawTargetCG and DrawTargetSkia, even though both the content and canvas pref are skia. We should not be alternating draw targets.
We're using DrawTargetCG to draw the native widget code. We can probably extract out the parts of DrawTargetCG that are used and limit the code to widget/cocoa after we turn on skia content.
Bug 942688 has patches to stop creating a DrawTargetCG for those cases (parts 4).
Depends on: 942688
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942688
You need to log in before you can comment on or make changes to this bug.