Closed Bug 123919 Opened 18 years ago Closed 16 years ago

"N" selects the next unread message in another folder but displays blank message

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: l.giustini, Assigned: sspitzer)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.8+) Gecko/20020205
BuildID:    

When you're on a folder and hit N to go to the next unread message that lays on
ANOTHER folder, Mozilla shows a blank message. The right title, but the body
disappears. To read the message, one must hit enter (and so open a window) or
double click on the title (same), or go back and forth untile message appears.
This happens on both the interfaces, so it's independent from it.
--Luciano

Reproducible: Always
Steps to Reproduce:
1.Open Mail/News
2.Select a message in any folder and check there's another unread message in
another folder (lower standing)
3.Then hit "N"
4.Notice the body is blank.
QA Contact: esther → laurel
Works for me in 2002021503 WinME
I'm discovering the same problem with Mozilla 0.9.9 (build 2002031104).
When reading news, everything is working fine. But reading mail gives troubles.
I have defined mailfilters, which sent mail to different subfolders. When I hit
N and the next unread is in a folder below the current folder, I get (sometimes)
an empty message. The workaround is already described above.

Marking a message unread, moving to a folder up the tree and hitting N gives no
problem (the previously "unread" marked message is shown as expected and marked
read again).
Sorry, I did some better testing. Hopefully it helps locating the problem.

Reproducable: always

Also when you mark a message "unread", and select a message in a folder up in
the tree, hitting N gives an empty message. (especially selecting the message in
the folder is important, only selecting the folder does not give troubles).

I hope you understand what I mean... :-)
Installed Mozilla on my computer at work. The same problem happens:
Build: 2002040103
OS: WinNT 4.0 SP6a
*** Bug 143935 has been marked as a duplicate of this bug. ***
Confirming based on comment 2 and comment 4.  From the dupe this still appears
in RC2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Going to N)ext unread message displays blank message → Going to next unread message displays blank message
Reproduced with 2002062808-trunk/Linux.
OS: Windows ME → All
confirming on 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
Works for me (build 2002082308, WinXP).
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

I can confirm that this now works for me as well. I just updated 
to Mozilla 1.1 from have been using Mozilla 1.0 where it did 
not work.
*** Bug 159992 has been marked as a duplicate of this bug. ***
Summary: Going to next unread message displays blank message → "N" selects the next unread message in another folder but displays blank message
Luciano Giustini, Roy Voortman: is this bug still an issue for you?  It appears 
to have been cleared up for a while, and I cannot reproduce the behavior in 1.3 
or 1.4b.  Please mark this bug Resolved|WorksForMe, unless you are still seeing 
it.
Using a Thunderbird build, I still get the bug sometimes - not as often, but
almost daily.
The bug still exists under linux debian, mozilla 1.0.1
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021122 Debian/1.0.1-2"

The bug is always reproductible, when using the button "Next", instead of "N"
The only responses to comment 12 were for either Thunderbird or for an older 
version of Mozilla than 1.1, which was cited (in comment 10) as no longer having 
the problem.  Setting this to WorksForMe (I haven't seen the problem with 1.3, 
1.4 or 1.5).  

Brian Matzon: If the bug does still appear in Thunderbird, please file a new 
T-bird specific bug.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
I still see the bug sometimes in Thunderbird 0.4a (20031026) on W2000PRO. It
shows the Thunderbird entry page instead of the message body..
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.