Closed Bug 1239367 Opened 7 years ago Closed 7 years ago

Remove/obsolete content about marketplace distribution to desktop/android, and WebRT

Categories

(Developer Documentation Graveyard :: Marketplace, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1243434

People

(Reporter: cmills, Assigned: cmills)

References

Details

This content is being removed very soon, so we ought to update the docs to remove mention of thee subjects.

So the following need to be removed or archived:

https://developer.mozilla.org/en-US/Marketplace/Options/Open_web_apps_for_android
https://developer.mozilla.org/en-US/Marketplace/Options/Open_web_apps_for_desktop

And sections like the following should be updated:

https://developer.mozilla.org/en-US/Marketplace/Publishing/Submit/Load_your_app#Platform_compatibility
Myk, can provide any more info you think I need? When should I do this by? Cheers.
Assignee: nobody → cmills
Blocks: 1239364
(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #1)
> Myk, can provide any more info you think I need? When should I do this by?
> Cheers.

I've added dependency references to the bugs about disabling the runtimes, as we should update these docs before we disable those runtimes.

Regarding timing, I don't know the details, and I can't find any public resources (bugs, plans) about it, but I'll add them here once I do.
Blocks: 1235869, 1238079
Sad to see this feature go, but understandable. However, regarding documentation, it would be helpful if you could document some alternative packaging/distribution methods for existing desktop OWAs now that this is going to be removed. E.g. can the current runtime be converted into some standalone desktop webapp packaging tool?
(In reply to Myk Melez [:myk] [@mykmelez] from comment #2)
> Regarding timing, I don't know the details, and I can't find any public
> resources (bugs, plans) about it, but I'll add them here once I do.

The details are now in https://discourse.mozilla-community.org/t/firefox-os-connected-devices-announcement/6864. tl;dr: "As of March 29, 2016, Marketplace will no longer accept submissions for Android, Desktop and Tablet, and will remove all apps that don’t support Firefox OS."

But dbialer filed duplicate bug 1243434, which now has some traction, so duping this bug to that one.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1243434
(In reply to Jeroen van der Gun from comment #3)
> Sad to see this feature go, but understandable. However, regarding
> documentation, it would be helpful if you could document some alternative
> packaging/distribution methods for existing desktop OWAs now that this is
> going to be removed.

Indeed, I filed bug 1248825 to track developing this documentation.


> E.g. can the current runtime be converted into some
> standalone desktop webapp packaging tool?

In theory, yes, but in practice this doesn't seem like a viable alternative, as it would require a lot of work.

In any case, let's discuss more in bug 1248825.
You need to log in before you can comment on or make changes to this bug.