Closed Bug 1240174 Opened 7 years ago Closed 7 years ago

layout.css.devPixelsPerPx set to 1.0 on HiDPI causes thin scrollbars and incorrectly aligned background in navigation toolbox

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox46 --- unaffected

People

(Reporter: arni2033, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [fixed by bug 1240180])

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160114060719
STR:
0. Set that DPI level -> 125% in your OS
1. Set layout.css.devPixelsPerPx -> 1.0
2. Restart Firefox
3. Open page   data:text/html,<style>body{height:10000px;}

Result:       
 1) Selected/hovered tab is clipped by the top side of screen by 1px
 2) Natively-styled scrollbars look compressed
 3) Window caption buttons (minimize-maximize-close) are clipped by toolbox background

Expectations: 
 Just like before bug 890156:
 1) Selected/hovered tab shouldn't be clipped by the top side of screen by 1px
 2) Natively-styled scrollbars should look just like in other applications
 3) Window caption buttons (minimize-maximize-close) should be fully-visible

This was triggered by bug 890156. Regression range:
>   https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98756a36223c1a2b51cd0368736b728429038caf&tochange=a9f9b36c1a2eec7626e6b749e46ab0a8bf3323e2

Note:
 Before somebody marks this "Wontfix", I want you to know that layout.css.devPixelsPerPx -> 1.0
 was the only workaround to the blurry thing firefox has become since version 24. It's impossible
 to use it on HiDPI: see my bugs about DPI and zoom level, and/or bug 1197497 comment 4.
Hm, I actually... described something wrong. There's an additional result: context menus look small
And also: all results are actually tolerable except for clipped caption buttons and clipped tabs.
Luckily it was fixed by
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee1922a13d8f (bug 1240180)
Though there're still some bugs with layout.css.devPixelsPerPx -> 1.
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: 1240180
Resolution: --- → WORKSFORME
Whiteboard: [fixed by bug 1240180]
You need to log in before you can comment on or make changes to this bug.