[MINOR ISSUE] FF 42.0 - did not directly update to the latest build but just to 43.0.1

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
minor
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Karl Heinz, Unassigned)

Tracking

43 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Updating FF 42.0 manually via About dialogue


Actual results:

FF 42 updated to 43.0.1 only


Expected results:

FF 42 should have downloaded 43.0.4 directly, but did this in a subsequent process after upgrading from FF 42 to 43.0.1.

Imho this might help to reduce upgrade time and traffic if a FF 42 release is updated right away to the latest build (43.0.4)
(Reporter)

Updated

2 years ago
Severity: normal → minor
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: update process → [MINOR ISSUE] FF 42.0 - did not directly update to the latest build but just to 43.0.1

Updated

2 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
The behavior you're seeing is intentional. 43.0.1 was a "watershed" release, meaning it's a forced intermediate stop between older and newer versions. The reason for doing a watershed there was to support switching to a SHA-2 code signing certificate for our binaries; see bug 1079858 for all the details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
See Also: → bug 1079858
You need to log in before you can comment on or make changes to this bug.