Closed Bug 1240347 Opened 6 years ago Closed 6 years ago

Huge regression when starting Twitter

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mihaibn, Unassigned)

Details

(Keywords: foxfood, perf, qawanted)

Attachments

(7 files)

I am using a Flame phone with the V5 Gonk running OTA 20160116150207 and since 1-2 days ago(I cannot say for sure) starting up Twitter takes almost 40 seconds on the Flame. During this time the screen gets black and the phone is completely blocked. Nothing works, not even the home button. After this, the icons reappear one by one, very slowly, as if the phone is running out of memory.

I have checked and I have the max memory allocated for the Flame, 1024 MB.

I have attached the complete logs.
Keywords: foxfood, perf
With today's OTA 20160117030243 Twitter doesn't even start. 1 minute after I clicked on the Twitter icon the screen got black and then I suppose the app crashed and then the homescreen started loading very slowly, icons kept reappearing one by one. I have added the 2-nd log with this OTA
Can QA reproduce?
Keywords: qawanted
Looking at the logs, that sounds very bad:
> 01-17 15:13:11.258   206   206 E GeckoConsole: [JavaScript Error: "TypeError: invalid 'in' operand details" {file: "resource://gre/modules/SystemAppProxy.jsm" line: 121}]
There is some twitter-related messages in the latest log above that error. There are also memory pressure related logs.
Attached file kernel killing apps
Looks like there is some OOM triggered.
Sounds a lot like bug 850175
This worked ok until this Saturday. That is a bug from 3 years ago
I am attaching yet another log, this time doing a different thing. I don't click on the Twitter app anymore, but I load www.twitter.com in the browser. I used OTA 20160118150203
Component: Performance → Gaia::Browser
What's interesting is that I see 1-2s janking also on my desktop browser when accessing Twitter.com. I use the latest Nightly 64 bit!
I can't reproduce the jank on desktop browser using the nightly.  There's a wait for the feed; that's twitter driven.  Having said that APC had been worked on last week.

12/21 build and the 1/12 build doesn't seem to have an issue as stated.

I tried reproducing the issue but I can't seem to.  I'm using 512 MB.
That's interesting that within 3 minutes he encountered memory errors if I read the log right?
Whiteboard: [dogfood-blocker]
Here is the bug I opened for the desktop browser: https://bugzilla.mozilla.org/show_bug.cgi?id=1240895
I attached many logs.

Now on Firefox OS Twitter has been crashing the whole thing for 1 minute or so.

I was able to get rid of the problem by deleting the Twitter app and reinstalling it. Now the issue is gone, but the question remains: why did this behaviour that I captured in the logs happened?
My guess is that it has to do something with the caching.
Twitter was also showing issues over the past several days : status.twitter.com
It could very well be that the cache for the app itself got corrupted.

Having said that, let's monitor for the next couple of days to see if you rerun into the issue.
I'm placing putting the nightly on hold until we see if this issue resurfaces for you.
It doesn't crash anymore Naoki, but the start up time takes a considerable amount of time on the Flame now.

Since the moment I press the Twitter app until it loads it takes 15s! This is really bad!
Btw to test, make sure that you are first logged in the Twitter app!
Here is the latest log with OTA 20160120030243. Twitter took around 20s to start! 

Once again, before trying this, make sure you are previously logged in, so that when you start Twitter it goes directly in your account and not to their login screen
Mihai, are you sure you didn't hit this issue before?  I'm pretty sure an older build with lots of cached information would probably hit a delay in launching twitter.

I'm guessing it's several days worth of cached information and keeping the phone up that caused you to get OOM killed.  Situations like that are harder to produce for QA as we flash our test phones everyday.
Since September 2015 I have been using Twitter daily and I was not bothered by it until last week around 15-16 january when it started crashing. It made the screen black for 1 minute and then the whole homescreen was repainted.

Yesterday I deleted Twitter and reinstalled it and the issue went away. But as you can see, when I start up Twitter now it takes between 15-20s to load. Indeed, it's probably the cache...but there is a regression somewhere as I never experienced so much jank as now.

On Android the Twitter app loads in an instant. Waiting so much for an app to load, no matter how much cache it has is not really acceptable from a user point of view. Now I am avoiding using the app on the phone because it has this behaviour.
Flags: needinfo?(mihaibn)
I am testing this again with the OTA of today 20160121030252 and it's really bad. The whole OS is blocked. Even the screen will get closed because the blocking stays for more than 1 minute.

I attached new logs. It's strange that no one else has this. It gets worse and worse as you keep using the phone. I don't think you can reproduce this on fresh phone without current usage.

Later I will upload a video
Attached file b2g-info.zip
I added the b2g-info dump
I'm reporting back after more days of testing!

I have disabled the experimental add-on (I have shared it on the fxdev mailing list) which I thought is responsible for the issue here. Still, 2 days after, twitter again took down the whole homescreen! Which is quite criminal from an app!

I applied the same solution: uninstall the app and reinstall it. It worked after this. But then I see how the performance degrades, especially after each OTA update (I do 2 per day). It now takes 40s to open Twitter. It doesn't crash anymore, but I feel it will do it again soon.
Please continue testing to see if it kills the OS again.  I can understand the not wanting to wait 40 seconds for it to load, and I agree that it's a regression that we should look into.

Having said that, I do not wish to block other dogfooders from getting more recent builds if twitter doesn't take down the whole system without the addon.
Flags: needinfo?(mihaibn)
I agree, no need to block this, I hope more people will report this soon...it cannot be only me :)
Flags: needinfo?(mihaibn)
QA Whiteboard: [QAnalyst-Triage+]
Whiteboard: [dogfood-blocker]
I don't have this issue anymore so I'm closing it
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.