Closed Bug 1240646 Opened 4 years ago Closed 4 years ago

Animations running on compositor kick restyling process on the main thread

Categories

(Core :: DOM: Animation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

Details

Attachments

(1 file)

I noticed this issue when I run the automation tests in bug 123528.
We wait 5 frames for animations running on the compositor, 2 frames are consumed for restyling process on my environment.  I guess half of the frames seem to be consumed for restyling. 

I don't know which bug causes this regression yet but I think it's very recently.
Blocks: 1232577
We should unthrottle animations even if there is no elements in mElementsToRestyle whenevent RestyleType::Throttled.

I don't attach any automation tests here because this issue is covered by the test in bug 1235286. I will land the test as soon as possible.
Assignee: nobody → hiikezoe
Attachment #8709255 - Flags: review?(bbirtles)
Attachment #8709255 - Flags: review?(bbirtles) → review+
https://hg.mozilla.org/mozilla-central/rev/c206156920e7
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.