[e10s] Fix test_bug414291.html to work in the absence of showModalDialog

RESOLVED FIXED in Firefox 46

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

(Blocks: 1 bug)

Trunk
mozilla46
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox46 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Bug 414291 looks like it was a regression from the landing of showModalDialog, wherein a window opened using window.open with modal=yes passed in was being opened as a modal dialog, but it shouldn't have been. The test checks that in two different scenarios with window.open we don't open a showModalDialog. These pass both with and without e10s. Arguably we're not in much danger of opening a modal window when we haven't implemented modal windows, but we might as well enable this.

The third test is this:
result3 = window.showModalDialog("data:text/html,<html><body onload='close(); returnValue = 3;'>");
is(result3, 3, "window didn't open as modal.");

I'm not entirely sure what this is testing. It just looks like a generic showModalDialog test. I could probably just delete it, but guarding it behind |if (window.showModalDialog)| makes it pass with e10s so I'll just do that.
(Assignee)

Comment 1

2 years ago
Created attachment 8709738 [details] [diff] [review]
Don't test showModalDialog in test_bug414291.html if it isn't defined.

I'm going to optimistically assume that the only reason this simple test doesn't work on any of these platforms is due to showModalDialogue.

I've only tested this locally, with and without e10s.
Attachment #8709738 - Flags: review?(mrbkap)

Updated

2 years ago
Attachment #8709738 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 2

2 years ago
try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b2213d70d226

Updated

2 years ago
Blocks: 984139
tracking-e10s: --- → +
(Assignee)

Comment 3

2 years ago
try for Android and B2G: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a946d43d4bb9&selectedJob=15696146

Comment 4

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/952331e23d98

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/952331e23d98
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.