The default bug view has changed. See this FAQ.

TestDllInterceptor fails on Windows 10 x64 with ntdll functions

RESOLVED FIXED in Firefox 52

Status

()

Core
General
RESOLVED FIXED
a year ago
5 months ago

People

(Reporter: aklotz, Assigned: aklotz)

Tracking

(Blocks: 1 bug)

Trunk
mozilla52
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

a year ago
Looks like there are TEST instructions in there that our code does not understand.
(Assignee)

Updated

a year ago
OS: Windows → Windows 10
Hardware: Unspecified → x86_64
(Assignee)

Comment 1

a year ago
Created attachment 8710030 [details] [diff] [review]
Patch

The DLL interceptor tests fail on Windows 10 without this patch. With this patch, they succeed.

I took the opportunity to add some smarts about modr/m and SIB bytes. Hopefully this will permit us to start taking more advantage of structure in the instruction set in the future.
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attachment #8710030 - Flags: review?(ehsan)
Comment on attachment 8710030 [details] [diff] [review]
Patch

Review of attachment 8710030 [details] [diff] [review]:
-----------------------------------------------------------------

::: xpcom/build/nsWindowsDllInterceptor.h
@@ +516,5 @@
> +          numBytes += 4;
> +        }
> +        break;
> +      default:
> +        // This should not be reachable

MOZ_ASSERT_UNREACHABLE please.
Attachment #8710030 - Flags: review?(ehsan) → review+
(Assignee)

Comment 3

a year ago
Created attachment 8710175 [details] [diff] [review]
Patch (r2)

Updated as requested. Carrying forward r+.
Attachment #8710030 - Attachment is obsolete: true
Attachment #8710175 - Flags: review+
(Assignee)

Comment 4

a year ago
Created attachment 8710177 [details] [diff] [review]
Patch (r3)

For real
Attachment #8710175 - Attachment is obsolete: true
Attachment #8710177 - Flags: review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 5

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f34b95fa1d0
Keywords: checkin-needed

Comment 6

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9f34b95fa1d0
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Backed out along with bug 1240848 under the suspicion that bug 1240848 was the cause of bug 1241921.
https://hg.mozilla.org/mozilla-central/rev/5f7c184ccd80
Status: RESOLVED → REOPENED
status-firefox46: fixed → ---
Resolution: FIXED → ---
Target Milestone: mozilla46 → ---
Depends on: 1241921
Aaron recommends that this bug block the 64-bit Firefox roll-out.
Blocks: 558448
(Assignee)

Comment 9

6 months ago
Created attachment 8800894 [details] [diff] [review]
Patch (r4)

Newly rebased. Carrying forward r+.
Attachment #8710177 - Attachment is obsolete: true
Attachment #8800894 - Flags: review+
(Assignee)

Comment 10

6 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/78344bbde6134a8be1c22d159730189c876205af
Bug 1240977: DLL interceptor improvements for Windows 10 x64 ntdll APIs; r=ehsan

Comment 11

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/78344bbde613
Status: REOPENED → RESOLVED
Last Resolved: a year ago6 months ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52

Updated

5 months ago
Depends on: 1314183
You need to log in before you can comment on or make changes to this bug.