Closed Bug 1241120 Opened 4 years ago Closed 3 years ago

Default icon is shown for context tile when loading more heavy content websites

Categories

(Hello (Loop) :: Client, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: bogdan_maris, Unassigned)

References

Details

Affected builds:
- latest Nightly 46.0a1

Affected OS's:
- Mac OS X 10.10.5
- Ubuntu 14.04 64-bit
- Windows 10 64-bit

STR:
1. Start Firefox
2. Make a conversation between two PCs or browsers
3. Load http://www.bbc.com/

Expected results: Context tile will have the correct globe icon in Conversation window.

Actual results: Context tile will have the default globe icon in Conversation window. It grabs the icon before the webpage had finished loading.

Notes:
- This is not a regression, it reproduces since the implementation from bug 1215612.
- I was able to reproduce with both normal loop server or stage.
- Screencast showing the issue: https://db.tt/OXD10zlo (was to big to upload it here).
I'm guessing that we're waiting for the page to fully load before trying to get the favicon, which may not be necessary.
Rank: 39
Priority: -- → P3
I think there's been some discussion recently about not notifying of tab/page change for a couple of seconds. That might help this a bit if we do change how that works.
Support for Hello/Loop has been discontinued.

https://support.mozilla.org/kb/hello-status

Hence closing the old bugs. Thank you for your support.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.