mix-blend-mode rendering broken on this page

RESOLVED FIXED in Firefox 46

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mstange, Assigned: dvander)

Tracking

({regression})

Trunk
mozilla46
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
On http://codepen.io/team/css-tricks/pen/ogrMQx there are black boxes around the text. Backing out part 2 from bug 1235995 fixes it.
Created attachment 8710502 [details] [diff] [review]
fix
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Attachment #8710502 - Flags: review?(mstange)
(Reporter)

Updated

3 years ago
Attachment #8710502 - Flags: review?(mstange) → review+

Comment 4

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a8215e9ef2ce
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Comment on attachment 8710502 [details] [diff] [review]
fix

Approval Request Comment
[Feature/regressing bug #]: Any one of bug 1243071, bug 1238496, bug 1235995 causes this regression.
[User impact if declined]: Broken rendering on pages with mix-blend mode.
[Describe test coverage new/current, TreeHerder]: Nightly >= 4 weeks
[Risks and why]: No risk; fixes correctness issue with CSS mix-blending. Please only uplift this only if one of bug 1243071, bug 1238496, or bug 1235995 gets uplifted.
[String/UUID change made/needed]:
Attachment #8710502 - Flags: approval-mozilla-aurora?
Comment on attachment 8710502 [details] [diff] [review]
fix

This needs to uplift with the other mix-blending work for APZ.
Attachment #8710502 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whoops, this looks like it already landed on Aurora as well.
You need to log in before you can comment on or make changes to this bug.