Note: There are a few cases of duplicates in user autocompletion which are being worked on.

BHR seems to store hang duration in wrong Telemetry bucket (off-by-one)

RESOLVED DUPLICATE of bug 1241362

Status

()

Toolkit
Telemetry
RESOLVED DUPLICATE of bug 1241362
2 years ago
2 years ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 1 bug)

46 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected)

Details

(Reporter)

Description

2 years ago
We have witnessed BHR reporting long hangs when in fact a much shorter hang had taken. We speculate it might be an off-by-one bug when the hang duration is stored in a Telemetry bucket.

STR:
1. Load about:telemetry
2. Hit F5 to refresh the page
3. Capture a profile

Expected: BHR should report a hang whose duration matches the time aboutTelemetry.js spends on the main thread
Actual: BHR seems to report a hang with double the duration

Sample profile: https://cleopatra.io/#report=a0f34b8d383c7c568a59911afe5b95a7a084fa4a&filter=%5B%7B%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A2615550,%22end%22%3A2617521%7D%5D&selection=0,1,2,3,4,5,6,7,8,10,44,45

BHR reported hangs of duration 511ms-1023ms when the profiler showed the event lasted about 300ms
(Reporter)

Updated

2 years ago
Blocks: 1241336

Comment 1

2 years ago
I can confirm with my STR:

E10s-disabled
1. Load about:telemetry
2. Open devtools console (Ctrl+Shift+K)
3. Run var now = Date.now(); while (Date.now() - now < 512) {}; console.log('done');
4. Refresh about:telemetry to display new results.

The 511 bucket did not increment and the 1023 bucket did.

I'm beginning to think the aboutTelemetry.js code is at fault. I think the data is fine, it's just being displayed wrong.
Blocks: 1241112
I'm almost sure I noticed something the same issue just by playing with statuser's thresholds, so I wouldn't bet on aboutTelemetry.js being the (only) culprit just yet.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1241362
You need to log in before you can comment on or make changes to this bug.