Corruption of window file associations

RESOLVED DUPLICATE of bug 131106

Status

--
major
RESOLVED DUPLICATE of bug 131106
17 years ago
5 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({qawanted})

Trunk
Future
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Two days ago, I downloaded Mozilla 0.9.8 and installed it, in a separate
directory as always.   It picked up my settings and details from Mozilla 0.9.7, BUT

it also changed the configuration of my computer to point a long list of file
types at Mozilla, and to rename them "Mozilla ..."

For example, GIF are now opened by Mozilla (not Paint Shop Pro 7) and are called
"Mozilla Graphics Interchange Format".   It's done the same with .ICO, .JPG,
.BMP, .MNG, and many more, some graphics, some text, and some I have no idea
about.   Some of them I have no idea of the original program that they were
opened by, and I cannot now access (for example) my Clipart compilations.

It took me a whole day to put back the ones I knew the original program for - in
many cases, the system would not accept the change back and I had to delete and
"reinitialise" them.

A very serious bug - I hope not too many people have suffered with it!

Comment 1

17 years ago
I thought this was a feature of moz for some time.  Did you try using the
Edit->Prefs->Advanced->System dialog to tell mozilla to unassociate itself with
those files?
->Browser. Why was this assigned to Mailnews? I'm really not sure which
component this should go to. Installer, perhaps?
Assignee: mstoltz → dveditz
Component: Security: General → Installer
Product: MailNews → Browser
QA Contact: junruh → bugzilla

Comment 3

17 years ago
sairuh- would this be yours?  file handling?

Comment 4

17 years ago
not installer
Assignee: dveditz → trudelle
Component: Installer → XP Apps
QA Contact: bugzilla → sairuh
This is done on purpose, and it can be undone through the prefs as mentioned or
by uninstalling Mozilla (we do preserve the previous setting). I'm sure this is
a WONTFIX or INVALID, but I'll reassign to law and see if he can think of any
changes that would make this more friendly or obvious (like maybe the file type
associations shouldn't be buried under Advanced, but be closer to Helper
Applications)
Assignee: trudelle → law
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

17 years ago
Further comments from reporter, following message that it was doing what it's
supposed to do...


Unfortunately, it goofed up my settings big-time, and I couldn't find out how to 
 get them back easily.   Turning them "off" again in Mozilla didn't restore the 
 previous settings.   It took me about three hours to get everything working 
 properly again.   What I said about Mozilla in the meantime can't be printed in 
 polite society!
 
Previous Mozilla installations didn't do this, so it's a new departure - and a 
 most unwelcome one!   I would *very much* prefer to see the default in Mozilla 
 as "don't change anything without asking".
 
Even Microsoft Internet Explorer didn't do THAT to me!
Keywords: qawanted

Updated

17 years ago
Blocks: 123929

Comment 7

17 years ago
Nominating so people can decide whether we need to fix this sooner rather than 
later.
Keywords: nsbeta1
Target Milestone: --- → mozilla1.0
QA Contact: sairuh → tpreston

Comment 8

17 years ago
nsbeta1- per Nav triage team
Keywords: nsbeta1 → nsbeta1-

Comment 9

17 years ago
Mass-moving all Navigator team 1.0 nsbeta1- bugs to 1.1
Target Milestone: mozilla1.0 → mozilla1.1

Comment 10

15 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future
Product: Core → Mozilla Application Suite

Updated

14 years ago
Assignee: law → guifeatures
Component: XP Apps → XP Apps: GUI Features
QA Contact: tpreston
Summary: Corruption of computer configuration → Corruption of window file associations
Whiteboard: DUPEME

Comment 11

14 years ago
dupe of "Make 'default browser' shouldn't steal image file associations from
image programs" (later but with more attention)

this has nothing to do with profiles

*** This bug has been marked as a duplicate of 131106 ***
No longer blocks: 123929
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.