[TV][2.5][Web Apps] Navigating between different app/website, icon has moving animation instead of just scaling

VERIFIED FIXED

Status

Firefox OS
Gaia::TV
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mlien, Assigned: joseph)

Tracking

(Blocks: 2 bugs)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [ft:conndevices][partner-blocker])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Description]
In Web Apps grid view, navigating between different app/website then the original icon has moving animation instead of just scaling

[Reproduce Steps]
1. Launch Apps -> Web Apps/Dev Web Apps
2. Navigating between app/website

[Build Information]
Environment: 2.5 Simulator
Gaia: https://github.com/mozilla-b2g/gaia/commit/184523b202608f24e01cda720370de3ee7c5b8c3
Gecko: https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/be1ec31308366db734d15a04db7c4b4697515b20
Mulet: https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/be1ec31308366db734d15a04db7c4b4697515b20 

[Expected Result]
Icon should just scaling
Focused icon from 100% -> 120%
De-focued icon from 120% -> 100%

[Actual Result]
Original icon has moving animation instead of just scaling
(Reporter)

Comment 1

2 years ago
[Blocking Requested - why for this release]: This is a much worse user experience
blocking-b2g: --- → 2.5?
QA Whiteboard: [COM=TV::Web Apps]
(Reporter)

Updated

2 years ago
Summary: [TV][2.5][Web Apps] Navigating between different app/website has moving animation instead of just scaling → [TV][2.5][Web Apps] Navigating between different app/website, icon has moving animation instead of just scaling
(Assignee)

Updated

2 years ago
Assignee: nobody → jyeh
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Created attachment 8710916 [details] [review]
jostw:josyeh/Marketplace/master/Bug1241407 > mozilla-b2g:master

Hi Davor, QA tested that the app icon scaling animation did not perform well under linux simulator. So I replace the img element inside the app icon with background image to solve this problem.

Thanks.
Attachment #8710916 - Flags: review?(dspasovski)
(Reporter)

Updated

2 years ago
See Also: → bug 1241829
(Assignee)

Updated

2 years ago
Attachment #8710916 - Flags: review?(dspasovski)
(Assignee)

Comment 3

2 years ago
Landed in marketplace-tv-front-end master.

https://github.com/mozilla-b2g/marketplace-tv-front-end/commit/18741d2d9193adddcf7966c9cff89ca9d1d01ab0
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

2 years ago
Bug still exists, need some improvement.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

2 years ago
Landed in marketplace-tv-front-end master.

https://github.com/mozilla-b2g/marketplace-tv-front-end/commit/f9acd68eeeafa4756c47e3581b281c6819344af3
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

2 years ago
verified and fixed with the latest 2.5 build
Status: RESOLVED → VERIFIED

Updated

2 years ago
Duplicate of this bug: 1244029

Updated

2 years ago
Blocks: 1214243
blocking-b2g: 2.5? → 2.5+
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-blocker]
You need to log in before you can comment on or make changes to this bug.