Closed Bug 1241471 Opened 4 years ago Closed 1 year ago

[Ubuntu] Unable to make Firefox the default browser

Categories

(Toolkit :: Preferences, defect, major)

All
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1056056
Tracking Status
firefox43 --- wontfix
firefox44 - wontfix
firefox45 + wontfix
firefox46 --- wontfix

People

(Reporter: bogdan_maris, Unassigned)

References

()

Details

(Keywords: regression)

Affected builds:
- Nightly 37.0a1
- Firefox 44.0 RC build 1 and 2
- Latest Aurora 45.0a2
- Latest Nightly 46.0a1

Unaffected builds:
- Firefox 43.0.4 RC
- Firefox 44beta9

Affected OS's:
- Ubuntu 14.04 32bit (two machines)

Unaffected OS's:
- Windows 10 32-bit
- Mac OS X 10.10.5

STR:
1. Start Firefox with a new profile
2. Click ''Use Firefox as my default browser'' when prompted
3. Click an URL from another application (skype, thunderbird etc.)

Expected results: The link opens in a new tab in Firefox.

Actual results: The link does not open in Firefox, it will not open at all.
Default applications shows that the default Web is Thunderbird by default.

Also 'sudo update-alternatives --config x-www-browser' will not show firefox in the list.

Notes:
- It`s strange that this bug reproduces on all Nightly builds I tested (37.0a1, 43.0a1, 44.0a1, 46.0a1), but does not reproduce using Firefox 43.0.4 RC and 44beta9 but it does in 44.0 both build 1 and 2.
- Using Firefox 43.0.4 RC: If You click ''Use Firefox as my default browser'' the second time it appears (which is also weird), will delete it as the default browser and will revert back to the previous (in my case Thunderbird). If I don't click ''Use Firefox...'' the pop-up will be shown over and over again, even though navigating to Default applications in Ubuntu will show that Firefox is the default browser. 
- I made a short video of how can it be reproduced https://db.tt/FKcMHBwT
[Tracking Requested - why for this release]: 
This bug directly impacts the user's ability to set Firefox as a default browser on Ubuntu.
Severity: normal → major
Keywords: regression
Justin, Jared: This seems to be a recent regression, since 44.0b9. We took a related fix for windows and wondering if you can help investigate this one as well. Thanks!
Flags: needinfo?(jaws)
Flags: needinfo?(dolske)
I'm looking in to this.
Ritu asked me to test this as well. I'm on Ubuntu 15.10, and couldn't reproduce with 43.0.4 nor 44.0 RC2. In both cases, I was able to set the default browser and open links from other applications. One weird thing I did notice was that I had to right click links from my terminal and click "open link" rather than just left clicking them. I'm not sure if this is normally in Unity, because I don't usually use it.
I am unable to reproduce this bug on Ubuntu 15.10 using Firefox 44 rc2.

I opened the System Settings > Details > Default Applications and set Browser as the default Web application.
Then I created a new Firefox profile ("defaultbrowsertest").
I launched by typing `./firefox -no-remote -p defaultbrowsertest`
When Firefox started up it asked if I wanted to make Firefox my default browser
I chose Yes, then opened the Firefox preferences
Firefox said that it was the default browser
I looked in the System Settings application and it still showed "Browser" as the default, however when I exited the "Details" view and re-entered the "Details" view, it now showed "Firefox" as the default Web application.

I'm not sure how you are getting that Bogdan. I looked through the changesets near the tip of Firefox Release and nothing seemed unusual per-platform or within the changesets that were related to default-browser code.

Bogdan, can you try testing on Ubuntu 15?
Flags: needinfo?(jaws) → needinfo?(bogdan.maris)
Given that at least two other people were *not* able to repro this bug, I don't think we should stop the RC 44.0-build2 from getting pushed to beta channel.
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)

> - It`s strange that this bug reproduces on all Nightly builds I tested
> (37.0a1, 43.0a1, 44.0a1, 46.0a1), but does not reproduce using Firefox
> 43.0.4 RC and 44beta9 but it does in 44.0 both build 1 and 2.

If you're seeing this all the way back to Firefox 37(!), that suggests to me that this is a long-standing bug in either Firefox or Gnome. Also weird that it's not reproducing on beta. Could you perhaps test a couple other versions of release and beta to see if this is oddly intermittent?

(I'll also note that bug 1240892, which landed for 44 RC2, only changes the Windows-specific shell service code. So I don't see how that could be involved here.)

Couple other observations:

In your video, when running RC2 there are a few "g_find_program_in_path: assertation program != NULL failed" console errors. I see 6, and you clicked the "Make Default" button in prefs 3 times... Can you confirm if clicking that button is causing these errors to show up, when it's not working?

Also, ps/top output that shows how Firefox is being launched (when invoked via a link in Thunderbird) could be helpful.
Flags: needinfo?(dolske)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> I am unable to reproduce this bug on Ubuntu 15.10 using Firefox 44 rc2.
> 
> I opened the System Settings > Details > Default Applications and set
> Browser as the default Web application.
> Then I created a new Firefox profile ("defaultbrowsertest").
> I launched by typing `./firefox -no-remote -p defaultbrowsertest`
> When Firefox started up it asked if I wanted to make Firefox my default
> browser
> I chose Yes, then opened the Firefox preferences
> Firefox said that it was the default browser
> I looked in the System Settings application and it still showed "Browser" as
> the default, however when I exited the "Details" view and re-entered the
> "Details" view, it now showed "Firefox" as the default Web application.
> 
> I'm not sure how you are getting that Bogdan. I looked through the
> changesets near the tip of Firefox Release and nothing seemed unusual
> per-platform or within the changesets that were related to default-browser
> code.
> 
> Bogdan, can you try testing on Ubuntu 15?

I installed both 15.10 32 and 64 bit in VirtualBox and I did not reproduce the issue. Same result with an Ubuntu 14.04 64-bit OS installed on my machine.

(In reply to Justin Dolske [:Dolske] from comment #7)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> 
> > - It`s strange that this bug reproduces on all Nightly builds I tested
> > (37.0a1, 43.0a1, 44.0a1, 46.0a1), but does not reproduce using Firefox
> > 43.0.4 RC and 44beta9 but it does in 44.0 both build 1 and 2.
> 
> If you're seeing this all the way back to Firefox 37(!), that suggests to me
> that this is a long-standing bug in either Firefox or Gnome. Also weird that
> it's not reproducing on beta. Could you perhaps test a couple other versions
> of release and beta to see if this is oddly intermittent?

I was unable to use mozregression since it does not recognize the beta repro... so I did a manually regression and in short this is what I was able to come up with. I went back as far as 36.0.4 which turn out to be good.

Regression:
Firefox 39.0.3 - Good
Firefox 40beta9 - Good
Firefox 40.0 - BAD
Firefox 40.0.1 - Good
Firefox 40.0.3 - Good 
Firefox 41.0 - Good
Firefox 42.0 - Good
Firefox 44.0 - BAD

After further testing, here are the information I can provide for good and bad builds:

Good:
- Default Applications is Firefox in Ubuntu settings.
- Opening link from Thunderbird will open the right Firefox version but will prompt me with the Default browser prompt and in Preferences it still shows that this is not default
- Opening link from Gimp or Skype will work as expected, will open the right Firefox version and in Preferences it is shown that this is default profile.

Bad:
- Default Applications is Firefox in Ubuntu settings.
- Clicking a link in Thunderbird does nothing.
- Clicking URL from Skype and Gimp(Help/GIMP Online/ any option) opens Profile manager with Firefox *44beta8* (for no reason that I can think of) which I already have on drive (the previous default browser was Chromium).
 
(In reply to Justin Dolske [:Dolske] from comment #7)
> Couple other observations:
> 
> In your video, when running RC2 there are a few "g_find_program_in_path:
> assertation program != NULL failed" console errors. I see 6, and you clicked
> the "Make Default" button in prefs 3 times... Can you confirm if clicking
> that button is causing these errors to show up, when it's not working?

The terminal output of the bad builds can be seen in pastebin (to much information to post here): http://pastebin.com/R5yFctAu

In a bad build if I go to about:preferences and click 'Make Default' button or click 'Use Firefox as my default browser' from Default Browser prompt, I will be receive this output:

(firefox:15666): GLib-CRITICAL **: g_find_program_in_path: assertion 'program != NULL' failed

(firefox:15666): GLib-CRITICAL **: g_find_program_in_path: assertion 'program != NULL' failed

(In reply to Justin Dolske [:Dolske] from comment #7)
> Also, ps/top output that shows how Firefox is being launched (when invoked
> via a link in Thunderbird) could be helpful.

I made a video with that, here it is: https://db.tt/HZ4nDdLi

Please let me know now can I help further on!
Flags: needinfo?(bogdan.maris)
This is not a new issue as mentioned in the comment above. Too late for Fx44. Nomi'ng for tracking in Fx45.
Looks like we will ship 45 with this issue too.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1056056
You need to log in before you can comment on or make changes to this bug.