Increase the limit for workers per-origin

RESOLVED FIXED in Firefox 47

Status

()

Core
DOM: Workers
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

36 Branch
mozilla47
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

(Whiteboard: [games:p1][platform-rel-Games])

Attachments

(3 attachments)

Created attachment 8710440 [details]
a (non-mochi-) test

Currently we limit to 20 per domain (bug 649537) but that is rather low, definitely less than in other 
browsers. Chrome doesn't seem to have a limit, but it just makes child process crash when around 50 workers 
are created (linux), or hang for awhile and crash the child process with ~750 workers (Windows). 
IE11 on Win7 limits to 25, and I was told Edge on Win10 has limit at 25 too.

Bug 1052398 is a bit noisy about various different things, so if we just want to make a simple increase to 
the limit, this is the separate bug for that.

I do think any application using lots of workers should be expected to send back a notification from the 
worker when it is loaded and then it can know how many workers it has to play with.
In other words, I'm not really a fan of { throwOnCreation: true } proposal.

Based on the behavior Chrome has on linux, I'm proposing we increase the limit to 50.
I'll push a patch with a mochitest which creates as many workers as possible to tryserver in order to
verify nothing really bad starts to happen if limit is increased.
Should we dupe bug 1222629 to this one?
Duplicate of this bug: 1222629
Created attachment 8710576 [details] [diff] [review]
+tweaks to the test
Attachment #8710576 - Flags: review?(khuey)
Desktop Safari seems to limit to 290 but it is not clear to me what kind of limit that is.
Not global and not per domain, but perhaps per top level window or something.

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4697704ff426
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Whiteboard: [games:p1]
Whiteboard: [games:p1] → [games:p1][platform-rel-Games]
You need to log in before you can comment on or make changes to this bug.