fix some job queue issues found through code inspection

RESOLVED FIXED in Firefox 45

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

unspecified
mozilla46
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 wontfix, firefox45 fixed, firefox46 fixed)

Details

Attachments

(4 attachments)

I see a few issues in the service worker job queue code.  I don't have any failing tests, but it would be nice to close these up.
Created attachment 8710515 [details] [diff] [review]
P1 Only pop jobs from the queue when the correct job completes. r=ehsan
Attachment #8710515 - Flags: review?(ehsan)
Created attachment 8710517 [details] [diff] [review]
P2 Move Cancel() to ServiceWorkerJob base class. r=ehsan
Attachment #8710517 - Flags: review?(ehsan)
Created attachment 8710518 [details] [diff] [review]
P3 Call Cancel() on all service worker jobs. r=ehsan
Attachment #8710518 - Flags: review?(ehsan)
Created attachment 8710519 [details] [diff] [review]
P4 Make service worker unregister job respect cancelation. r=ehsan

https://treeherder.mozilla.org/#/jobs?repo=try&revision=53a0d2748174
Attachment #8710519 - Flags: review?(ehsan)

Updated

3 years ago
Attachment #8710515 - Flags: review?(ehsan) → review+

Updated

3 years ago
Attachment #8710517 - Flags: review?(ehsan) → review+

Updated

3 years ago
Attachment #8710518 - Flags: review?(ehsan) → review+

Updated

3 years ago
Attachment #8710519 - Flags: review?(ehsan) → review+
On my mobile so I can't star in treeherder easily, but all the try orange looks like known intermittent to me.
Keywords: checkin-needed

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cca3ee01a862
https://hg.mozilla.org/mozilla-central/rev/62452453a636
https://hg.mozilla.org/mozilla-central/rev/9979b9c3314a
https://hg.mozilla.org/mozilla-central/rev/ae7300dbece6
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Comment on attachment 8710515 [details] [diff] [review]
P1 Only pop jobs from the queue when the correct job completes. r=ehsan

For all 4 patches.

Approval Request Comment
[Feature/regressing bug #]: service workers
[User impact if declined]: Possible crash if certain code paths are hit.
[Describe test coverage new/current, TreeHerder]:  Current mochitests ensure no regressions, but we don't have a test that provokes the crash.
[Risks and why]: Minimal.  Only affects service workers.
[String/UUID change made/needed]: None
Attachment #8710515 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

3 years ago
status-firefox44: --- → wontfix
status-firefox45: --- → affected
Comment on attachment 8710515 [details] [diff] [review]
P1 Only pop jobs from the queue when the correct job completes. r=ehsan

Fix a crash, taking it.
Attachment #8710515 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

3 years ago
Depends on: 1244330
Blocks: 1234949
You need to log in before you can comment on or make changes to this bug.