Closed Bug 12417 Opened 21 years ago Closed 20 years ago

[PP] Clicking on Format removes text highlighting in Editor

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: blee, Assigned: buster)

Details

Steps to reproduce:
1) Type a word (Roman, CJK or of any script) in Editor.
2) Highlight it and click on Format menu.

==> Clicking Format clears the selection (highlight), making it impossible to
    edit the text input.   bld: 1999-08-20-16-M9
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → REMIND
Just learned the feature isn't implemented yet. Switching to Remind
Status: RESOLVED → REOPENED
Reopening - Linux is the only platform where it's not implemented.
Status: REOPENED → NEW
Status: NEW → ASSIGNED
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Resolution: REMIND → ---
Summary: Clicking on Format removes text highlight in Editor → [PP] Clicking on Format removes text highlight in Editor
Bom-Shik--I can't reproduce this bug on Mac; the format menu works fine.  Can you
clarify: is there a particular menu item that doesn't work in the Format menu or
is it that you can't even see the items in the format menu?

Set to [PP] since it sounds like it's Windows (or Linux?) only.
bug fixes moved to M12
Summary: [PP] Clicking on Format removes text highlight in Editor → [PP] Clicking on Format removes text highlighting in Editor
Sujay -- can you try this and see if this is still a problem -- thanks
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
checked thia on linux using the 19991112 build and it works fine, using build
19991111 on win95 it works fine, using 19991111 on Mac it also works fine. The
format is not removed. Marking fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This bug is not about format being removed. It's about "highlight" being cleared
when Format menu is selected - Please read Summary and description carefully.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I did read the summary, I do understand the issue and it is fixed, marking
fixed.
Status: RESOLVED → VERIFIED
verified in 11/29 build.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Reopening as it happens again (regressed) in these blds:
Win 12-08-16-M12, Mac 12-09-10-M12, Linux 12-08-89-M12.
Try to reproduce the error with the self-install executable (downloaded and
installed 12-12-99).  Clicking Format and applying a different color worked
fine.  I used this as test: This is some <font color="blue">text that i
am</font> going to edit.  Just a FYI.
Sorry folks, only tested this for Win32.
asked Sujay to check on Mac & Linux, he will update the bug
I cannot reproduce this on Win, Linux or Mac using 12/13 builds.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Oddly enough this doesn't happen in 12/13 blds:
Win32 12-13-09-M12, Linux 12-13-08-M12, Mac 12-13-08-M12.
Resolving as fixed for now.
Status: RESOLVED → VERIFIED
verified in 12/13 build.
Blocks: 22176
No longer blocks: 22176
You need to log in before you can comment on or make changes to this bug.