custom keywords substitute only first instance of %s rather than all instances

VERIFIED DUPLICATE of bug 98749

Status

VERIFIED DUPLICATE of bug 98749
17 years ago
14 years ago

People

(Reporter: m_mozilla, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I don't care for the bugzilla search which comes with mozilla. I wanted to put
in my own search with custom keywords. I wanted that search to be the same as
what you get when you use the form in the upper left of bugzilla.mozilla.org.

The appropriate query inserts your search string in a few places, so I put %s in
those places:

http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-0=product&type0-0-0=substring&value0-0-0=%s&field0-0-1=component&type0-0-1=substring&value0-0-1=%s&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=%s&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=%s

Unfortunately, this results in a search for %s rather than what I wanted...
because mozilla only substituted my query into the *first* instance of %s rather
than every instance.
(Reporter)

Comment 1

17 years ago
how about that: they even found the bug using the same URL :)

-matt


*** This bug has been marked as a duplicate of 98749 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe

dawn would be proud
Status: RESOLVED → VERIFIED
Summary: custom keywords substitue only first instance of %s rather than all instances → custom keywords substitute only first instance of %s rather than all instances
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.