TEST-UNEXPECTED-ERROR | test_utils.py TestSanitize.test_sanitize_cookies | ScriptTimeoutException: ScriptTimeoutException: timed out

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

(Depends on 1 bug, {intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

As it looks like this started yesterday. Sadly no more output available:

https://treeherder.mozilla.org/logviewer.html#?job_id=3148337&repo=mozilla-central

 06:56:22 INFO - TEST-UNEXPECTED-ERROR | test_utils.py TestSanitize.test_sanitize_cookies | ScriptTimeoutException: ScriptTimeoutException: timed out
Looks like Marionette also throws fails here in getting the error details:

 06:56:22     INFO - Traceback (most recent call last):
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\marionette\marionette_test.py", line 344, in run
 06:56:22     INFO -     testMethod()
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\firefox_ui_tests\puppeteer\test_utils.py", line 44, in test_sanitize_cookies
 06:56:22     INFO -     self.utils.sanitize(data_type={"cookies": True})
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\firefox_puppeteer\api\utils.py", line 90, in sanitize
 06:56:22     INFO -     """, script_args=[data_type])
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1732, in execute_async_script
 06:56:22     INFO -     rv = self._send_message("executeAsyncScript", body, key="value")
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\marionette_driver\decorators.py", line 36, in _
 06:56:22     INFO -     return func(*args, **kwargs)
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\marionette_driver\marionette.py", line 747, in _send_message
 06:56:22     INFO -     self._handle_error(err)
 06:56:22     INFO -   File "c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\marionette_driver\marionette.py", line 808, in _handle_error
 06:56:22     INFO -     raise errors.lookup(error)(message, stacktrace=stacktrace)
 06:56:22     INFO - TEST-INFO took 21971ms
 06:56:22     INFO - TEST-START | test_utils.py TestSanitize.test_sanitize_history
 06:56:22     INFO -  MARIONETTE LOG: INFO: TEST-END: c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\firefox_ui_tests\puppeteer\test_utils.py:test_sanitize_cookies
 06:56:22     INFO -  MARIONETTE LOG: INFO: TEST-START: c:\jenkins\workspace\mozilla-central_functional\build\venv\lib\site-packages\firefox_ui_tests\puppeteer\test_utils.py:test_sanitize_history
 06:56:23     INFO -  *************************
 06:56:23     INFO -  A coding exception was thrown in a Promise resolution callback.
 06:56:23     INFO -  See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
 06:56:23     INFO -  Full message: TypeError: that.sandboxes[sandboxName] is undefined
 06:56:23     INFO -  Full stack: GeckoDriver.prototype.executeWithCallback/res</chromeAsyncReturnFunc@chrome://marionette/content/driver.js:1094:1
 06:56:23     INFO -  __marionetteFunc/<@utils.py:39:17
 06:56:23     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:933:23
 06:56:23     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:812:7
 06:56:23     INFO -  Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:743:11
 06:56:23     INFO -  this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:775:7
 06:56:23     INFO -  this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:710:7

Andreas, not sure if the underlying Marionette server issue here is causing this but I assume its something we should get fixed in case a script times out. I might have to file a new bug for that.
Flags: needinfo?(ato)
Are you certain this is a regression?  Regardless, it might be something that will get solved with bug 1123506, as it provides a complete refactor of the evaluate script functions.
Flags: needinfo?(ato)
Might be possible. Lets add it as dep for now.
Depends on: 1123506
This should be related to bug 1243485 and hopefully be fixed via bug  	1245065.
Depends on: 1245065
No longer depends on: 1123506
Looks like this got already fixed by the landing of the patch on bug 1243485.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.