option to switch to reader view should pop up on plain text content

RESOLVED DUPLICATE of bug 1154295

Status

()

RESOLVED DUPLICATE of bug 1154295
3 years ago
3 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

text/plain links should also have a reader mode icon to open them in reader mode -- e.g. http://mathforum.org/kb/plaintext.jspa?messageID=9847854 .  text/plain links in general suck on mobile -- the text is always too small to read without zooming in, and lines don't wrap.

If it doesn't do this already, offering reader mode, and having reader mode do some simple stuff like turn lines of text separated by blank lines into paragraphs that reflow would make it much more useful.
I could have sworn we already had a bug on this.
Component: Reader View → Reader Mode
Product: Firefox for Android → Toolkit

Comment 2

3 years ago
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> I could have sworn we already had a bug on this.

I also can't find a bug, but I do remember discussing this.

The readability algorithm works by detecting <p> and <div> elements, but I don't see why we couldn't just load the unprocessed plain text in reader view. It might not look as nice as if we set paragraphs, but it would at least let people change the font around.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154295
You need to log in before you can comment on or make changes to this bug.