Wrap-around to left does not work in login/register form

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: cbadescu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

3 years ago
Steps to reproduce:
1.In “Dev Web Apps” navigate to a desired app and press “OK”(“Enter” key on the keyboard).
2.In app content go to login/register icon and press “OK”(“Enter” key on the keyboard).
3.Press&hold right arrow and navigate to right until wrap-round
4.Press&hold left arrow and navigate to left.

Expected results:
When navigating to left wrap-around should work.

Actual results:
When press&hold left arrow the focus stop at the top left button. 

Note/Issues:
Environment: 2.5 Simulator.
This issue is reproducing in -dev server. 
Video for this issue: https://www.dropbox.com/s/lwo4rw4lkldajq0/Wrap-around%20to%20left.mp4?dl=0
Blocks: 1187806
No longer blocks: 1204762
Priority: -- → P2

Comment 1

3 years ago
It's a content issue, not WebApps issue.
Michael, are you the right person to deal with content issue?
Flags: needinfo?(mellis)

Comment 2

3 years ago
Hey Evelyn, 

This bug refers to the on-screen keyboard which appears when the user needs to type input into a field on TV.  

The bug is to allow wrap-around to occur (i.e. if the key "A" is highlighted on screen, pressing left arrow should wrap focus around to right-most character on same row "L")

The same OS level keyboard is used across most TV apps.  This is an OS bug.

Do you agree?
Flags: needinfo?(mellis) → needinfo?(ehung)

Comment 3

3 years ago
I just this claim on the TV's om screen keyboard (v2.1).  

I can confirm that wrap-around on the keyboard is supported/working now.  (WFM)

@ Cosmin - can you please provide a video of your experience, as your seeing it?
Flags: needinfo?(cosmin.badescu)

Comment 4

3 years ago
Uploaded video of my experience here:   https://youtu.be/mso6FBYtnx0

Comment 5

3 years ago
If this bug is about OS level keyboard, let's close it as invalid. because virtual keyboard on TV is done by partner, not existing in our codebase. On simulator, we even don't include a keyboard app in the build. Please ignore any keyboard issue. Thanks.
Flags: needinfo?(ehung)

Comment 6

3 years ago
I think you are right, Evelyn. But let's first take a look at Cosmin's experience before closing this out.
(Reporter)

Updated

3 years ago
Flags: needinfo?(cosmin.badescu)
(Reporter)

Comment 7

3 years ago
I do not have on-screen keyboard I am using a physical keyboard. https://www.dropbox.com/s/ixrf9atqi9nga6x/Display-keyboard.mp4?dl=0
(Reporter)

Comment 8

3 years ago
In search it works, wrap-around to left does not work in login/register form.

Updated

3 years ago
Whiteboard: [ft:conndevices]

Comment 9

3 years ago
Since web apps won't in 2.6 scope, this issue is not valid anymore after removing web apps from our build.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.