Closed Bug 1242958 Opened 4 years ago Closed 4 years ago

[DevTools][Memory] The cursor type is not I-beam when the mouse pointer is over the heap-view

Categories

(DevTools :: Memory, defect, P3)

defect

Tracking

(firefox44 affected, firefox45 affected, firefox46 affected, firefox47 fixed)

RESOLVED FIXED
Firefox 47
Tracking Status
firefox44 --- affected
firefox45 --- affected
firefox46 --- affected
firefox47 --- fixed

People

(Reporter: magicp.jp, Assigned: gregtatum)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160125060632

Steps to reproduce:

1. Start Firefox 44.0 or later version
2. Open Memory tool
3. Run "Take Snapshot..."
4. The mouse pointer over the heap-view


Actual results:

The cursor type is I-beam when the mouse pointer is over the heap-view


Expected results:

The cursor type is default.
Has STR: --- → yes
Component: Untriaged → Developer Tools: Memory
OS: Unspecified → All
Hardware: Unspecified → All
Priority: -- → P3
Assignee: nobody → gtatum
I adjusted the i-beam cursor, and also fixed it so that selections would be visible.
They were sharing the same color as the focused element. I inverted the colors on
the selection to make it obvious what was going on. I also made the behavior
consistent on the selection of the heap snapshots. It feels a lot more obvious
right now what exactly is going on when you are hovering and selecting things.
Attachment #8725254 - Flags: review?(nfitzgerald)
Comment on attachment 8725254 [details] [diff] [review]
The cursor type is not I-beam when the mouse pointer is over the heap-view

Review of attachment 8725254 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8725254 - Flags: review?(nfitzgerald) → review+
So I went ahead and ran this through the try server even though it's only some CSS changes. I have a bunch of seemingly unrelated test fails. What should I do in this case?

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a1c11f5074b2
(In reply to Greg Tatum [:gregtatum] [@gregtatum] from comment #3)
> So I went ahead and ran this through the try server even though it's only
> some CSS changes. I have a bunch of seemingly unrelated test fails. What
> should I do in this case?
> 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=a1c11f5074b2

I think you just got unlucky with intermittents (this shows why we need to take them seriously! because they impact so much more than just being a flaky test). I would try retriggering the failing suites a few times each (click on the failure and press "R"). It is also possible you pushed on a tip that was broken-ish, in which case you could rebase on the latest m-c and push to try again.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4456bd3af75c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
I have reproduced this bug with Firefox aurora 46.0a2(build ID:20160220004011)on 
windows 7(64 bit)

I have verified this bug as fixed with Firefox nightly 48.0a1(build ID:20160421030302)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

[bugday-20160427]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.