XPI install stops 3/4 way through download

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: mozbug1, Assigned: dveditz)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415



Reproducible: Always
Steps to Reproduce:
1. Go to
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.8/linux-xpi/talkback.xpi
2. Accept the install
3.

Actual Results:  download stalled when progress bar was about 3/4 done.  I
couldn't cancel it (bug 84461) except by quiting mozilla, which gave me:
/usr/local/mozilla0.9.8/run-mozilla.sh: line 72:  2130 Segmentation fault     
$prog ${1+"$@"}

Anyway this happend again and again, so I download the file locally and tried to
install it by going to ftp://localhost/talkback.xpi but it stalled in the same
place!

Expected Results:  The talkback should have been installed.

I was able to install it by going to
javascript:InstallTrigger.startSoftwareUpdate("file://download/talkback.xpi")

This doesn't appear to be a dupe of any bug that I was able to find, but may be
related to some.

Should this component by xpidl?  I'm not sure.

Comment 1

17 years ago
[bugzilla component to be deleted]
Assignee: scc → dveditz
Component: XP Utilities → Installer: XPInstall Engine
QA Contact: scc → jimmylee
Reporter, could you reproduce this with RC1 ?
(Reporter)

Comment 3

17 years ago
Nope. It now works with 1.0 rc1 on linux.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
Marking Verified!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.