TypeError: searchbar.inputChanged is not a function from UITour.jsm running browser_UITour3.js

RESOLVED FIXED in Firefox 47

Status

()

Firefox
Tours
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: MattN, Assigned: florian)

Tracking

({regression})

43 Branch
Firefox 47
regression
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

A coding exception was thrown in a Promise resolution callback.
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
Full message: TypeError: searchbar.inputChanged is not a function
Full stack: this.UITour.onPageEvent/<@resource:///modules/UITour.jsm:664:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:933:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:812:7
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:743:11
this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:775:7
Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:450:5
this.UITour.getTarget@resource:///modules/UITour.jsm:959:5
this.UITour.onPageEvent@resource:///modules/UITour.jsm:660:29

Florian, do you know the story behind this? It seems like the implementation of setSearchTerm is stale. Can we fix it or remove it?
Flags: needinfo?(florian)
(Assignee)

Comment 1

2 years ago
(In reply to Matthew N. [:MattN] from comment #0)

> Florian, do you know the story behind this? It seems like the implementation
> of setSearchTerm is stale. Can we fix it or remove it?

I don't know if/how setSearchTerm is/was used, unfortunately. But the JS error you report looks like my mistake: http://hg.mozilla.org/mozilla-central/diff/43d39d5f35b2/browser/components/search/content/search.xml#l1.264
Blocks: 1119250
Flags: needinfo?(florian)
Keywords: regression
(Assignee)

Comment 2

2 years ago
Created attachment 8712631 [details] [diff] [review]
Fix
Attachment #8712631 - Flags: review?(MattN+bmo)
(Assignee)

Updated

2 years ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8712631 - Flags: review?(MattN+bmo) → review+
I also removed the catch with Cu.reportError so the test would have failed when this bug got instroduced.

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b705b2fab063
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Version: unspecified → 43 Branch
You need to log in before you can comment on or make changes to this bug.