[TV][2.5] "Done" button overlaps the background string in "Send to TV" tutorial page.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::TV
P3
minor
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: cindylee, Assigned: Fischer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8713068 [details]
NG.jpg

[Description]
[TV][2.5] "Done" button overlaps the background string in "Send to TV" tutorial page.

[Test Steps]
1. Launch "Send to TV" app in Apps Deck
2. Press OK and go to next page
3. Press "Learn how to send tabs from your Android device" button
4. "Done" button overlaps the background string.

[Expected Result]
4. "Done" button should NOT overlap the background string.

[Actual Result]
4. "Done" button overlaps the background string.

[Frequency]
5/5

[Build Info]
Environment: 2.5 Simulator
gaia:https://github.com/mozilla-b2g/gaia/commit/8a0d9deb2cd47df25750ed2c6820909e4feac3bb
gecko:https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328
mulet:https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/2b6f8826861a846c3d1d98ef595c8dfbf8b59328

Comment 1

2 years ago
[Blocking Requested - why for this release]: UI needs to be polished
Blocks: 1239346
blocking-b2g: --- → 2.5?

Comment 2

2 years ago
To me it's not blocking shipping so I won't say it a blocker. Because it's a remote page and we can always fix this bug after the due date, so assign to Fischer first.
Assignee: nobody → fliu
blocking-b2g: 2.5? → ---
(Assignee)

Comment 3

2 years ago
It looks like this is because the resolution of monitor is too small.
The app is designed to fit into 1920x1080 screen (like real TV).
If the screen was smaller than 1920x1080, the app would be squeezed.
Please verify with a monitor larger than 1920x1080 screen resolution, thanks.
Flags: needinfo?(cindylee)
(Reporter)

Comment 4

2 years ago
(In reply to [:Fischer]Fischer from comment #3)
> It looks like this is because the resolution of monitor is too small.
> The app is designed to fit into 1920x1080 screen (like real TV).
> If the screen was smaller than 1920x1080, the app would be squeezed.
> Please verify with a monitor larger than 1920x1080 screen resolution, thanks.

This issue happens on the monitor which is supported 1920x1080.
I also check the same page on the monitor which is supported 3840x2160 and the issue is NOT observed.
Thanks.
Flags: needinfo?(cindylee)
(Assignee)

Comment 5

2 years ago
It is that the "screen area" for app has to be 1920x1080.
If the monitor is just 1920x1080, then, after subtracting the area occupied the window frame and other system bar, the screen area will not be enough for 1920x1080.
That is why we have to verify with a monitor larger than 1920x1080 screen resolution.
Flags: needinfo?(cindylee)

Comment 6

2 years ago
Created attachment 8713477 [details]
Screenshot from 2016-01-29 12:51:54.png

Hi Cindy, I also use the simulator preset resolution 1920x1080 and I don't see the overlap situation.

Please confirm it again and if both resolution 1920x1080 and larger than 1920x1080 cannot reproduce it, this will be low priority.
(Reporter)

Comment 7

2 years ago
(In reply to Mike Lien[:mlien] from comment #6)
> Created attachment 8713477 [details]
> Screenshot from 2016-01-29 12:51:54.png
> 
> Hi Cindy, I also use the simulator preset resolution 1920x1080 and I don't
> see the overlap situation.
> 
> Please confirm it again and if both resolution 1920x1080 and larger than
> 1920x1080 cannot reproduce it, this will be low priority.

Hi Mike,

According to Fischer's comment, I hide the tool bar and minimize the title bar.
The overlap issue is NOT observed anymore.
Please refer to the attachment.
Flags: needinfo?(cindylee)
(Reporter)

Comment 8

2 years ago
Created attachment 8713484 [details]
Screenshot from 2016-01-29 133545.png

Comment 9

2 years ago
This is the problem of combination between resolution and simulator window size, not TV build's issue.
According to comment 7, this will be lower priority.
Priority: -- → P3
(Assignee)

Comment 10

2 years ago
Since this is about the simulator resolution size handling and happens to all Gaia app, not coding issue, we will not address it only in this "Send to TV" tutorial app. If we want to fix this kind of issue, we should open another two bugs:
- Bug 1: Make the simulator handle the resolution size issue on screen smaller than 1920x1080.
- Bug 2: UI and UX should design and consider the case what to do if 1920x1080 screen size is unavailable.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.