Hand tool not displayed while hovering over Sign in to Sync from Sync tabs panel

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45 affected, firefox46 affected, firefox47 affected)

Details

Affected builds:
- Firefox 45beta1
- latest Developer Edition 46.0a2
- latest Nightly 47.0a1

Affected OS's:
- Windows 10 64bit
- Mac OS X 10.10.5
- Ubuntu 14.04 32bit

STR:
1. Start firefox
2. Click Synced Tabs (reproduces from panel/menu/toolbar)
3. Hover with the cursor over Sign in to Sync

Expected: The hand tool is displayed just like in Pocket, Hello, Forget panels.

Actual results: Normal cursor is displayed.

Notes:
- This is not a recent regression, it reproduces back in Nightly from 2015-12-04 where this feature was enabled by default.
status-firefox45: --- → affected
status-firefox46: --- → affected
This looks like a polish issue that hasn't yet shipped. Not a show stopper but better to correct before the feature is released.

Dolske - Can you help find an owner?
status-firefox44: --- → unaffected
Flags: needinfo?(dolske)
Feels like a followup fix for Mark, since he did the original?
Flags: needinfo?(dolske) → needinfo?(markh)
I'm not sure this is what we want - the "Sign in to Sync" element is a button (not a link), so the normal cursor seems correct. This is the same as when the button is shown in Sync Prefs - the signin button doesn't get a different cursor. Note that the links (eg, to download Firefox for IOS/Android) *do* get the cursor.

In short, my understanding is that buttons get the normal cursor (all buttons - both toolbar buttons and buttons inside panels), while links get the hand cursor, so I think this is WONTFIX - but delegating to rfeeley for the final say.

(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> Expected: The hand tool is displayed just like in Pocket, Hello, Forget
> panels.

If I click the "Forget" button I can't see the hand cursor for any element, including the main button.

If I click the Hello button in an e10s window I get a message that it doesn't work with e10s then a button allowing me to open a new window - this also doesn't get the hand cursor. Once I do open a new non-e10s window the button there *does* get a hand - so Hello isn't consistent.
Flags: needinfo?(markh) → needinfo?(rfeeley)
Mark is right, the hand cursor is likely an artifact of them being web content. This is not the way other buttons and links work elsewhere in the browser. I'll check with Shorlander to see if he thinks we should change Pocket/Hello to match, but I think we can close this.
Flags: needinfo?(rfeeley)
(i meant "only links")

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.