[TV][2.5] Reset and no longer count "open times" after app was added

VERIFIED FIXED

Status

Firefox OS
Gaia::TV::System
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: rickychien, Assigned: rickychien)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 attachments)

Created attachment 8713499 [details]
marketplace-tv-160129.pdf

According UX spec P.29 as attachment, we should reset and no longer count "open times" after app was added because it will run into a weird scenario when user opens up website's preview window in X times and add and then remove that website by option key. Once user removes that website will close preview window instantly and prompt the "Add {app name} to Apps?" dialog after then. It's an unintuitive use case should be fixed.

Updated

2 years ago
feature-b2g: --- → 2.5+
(Assignee)

Updated

2 years ago
Summary: [TV] Reset and no longer count "open times" after app was added → [TV][2.5] Reset and no longer count "open times" after app was added
Created attachment 8714834 [details] [review]
[gaia] rickychien:reset-open-times > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8714834 - Flags: review?(lchang)

Comment 2

2 years ago
Comment on attachment 8714834 [details] [review]
[gaia] rickychien:reset-open-times > mozilla-b2g:master

Two comments:

1. Could you write a function for resetting the counter in PreviewWindow?
2. Make the timing more consistent. (e.q. right before showing "added to apps")
Attachment #8714834 - Flags: review?(lchang)
(Assignee)

Updated

2 years ago
Attachment #8714834 - Flags: review?(lchang)

Comment 3

2 years ago
Comment on attachment 8714834 [details] [review]
[gaia] rickychien:reset-open-times > mozilla-b2g:master

Good to go!
Attachment #8714834 - Flags: review?(lchang) → review+
(Assignee)

Comment 4

2 years ago
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/14ab87ef3ac912a949da1d214eb875c5798246a5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

2 years ago
Comment on attachment 8714834 [details] [review]
[gaia] rickychien:reset-open-times > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): new feature
[User impact] if declined: minor
[Testing completed]: verified manually on simulator
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8714834 - Flags: approval-gaia-v2.5?
(Assignee)

Comment 6

2 years ago
Created attachment 8715637 [details]
patch uplifts to v2.5

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): new feature
[User impact] if declined: minor
[Testing completed]: verified manually on simulator
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8715637 - Flags: approval-gaia-v2.5?
(Assignee)

Updated

2 years ago
Attachment #8714834 - Flags: approval-gaia-v2.5?

Updated

2 years ago
Whiteboard: [ft:conndevices]

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed

Comment 8

2 years ago
Comment on attachment 8715637 [details]
patch uplifts to v2.5

Approve for TV 2.5
Attachment #8715637 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Assignee)

Comment 9

2 years ago
For uplifting to v2.5:

curl -L https://github.com/rickychien/gaia/commit/dd27921c5a851bf5805da3a87e59de9aa88c0d94.patch | git am
Flags: needinfo?(cbook)
Hi Ricky, i did this and got :

Applying: Bug 1244020 - [TV][2.5] Reset preview window open times
error: patch failed: tv_apps/smart-system/js/app_install_manager.js:45
error: tv_apps/smart-system/js/app_install_manager.js: patch does not apply
Patch failed at 0001 Bug 1244020 - [TV][2.5] Reset preview window open times
The copy of the patch that failed is found in: .git/rebase-apply/patch
When you have resolved this problem, run "git am --continue".
If you prefer to skip this patch, run "git am --skip" instead.
To restore the original branch and stop patching, run "git am --abort".
Flags: needinfo?(cbook) → needinfo?(rchien)
curl -L https://github.com/rickychien/gaia/commit/6f1847582a080856c4c9cc669618a6b6a839e46c.patch | git am
Flags: needinfo?(rchien) → needinfo?(cbook)
https://github.com/mozilla-b2g/gaia/commit/28880004bc5cd6e129d0a23b701a389753788ed0
status-b2g-v2.5: affected → fixed
Flags: needinfo?(cbook)
We verified on simulator version 2.6.20160221014426.
gaia:
https://github.com/mozilla-b2g/gaia/commit/a6ecae635719115aa72465efe522fdced3dd1d70
gecko:
https://hg.mozilla.org/mozilla-central/rev/af6356a3e8c56036b74ba097395356d9c6e6c5a3

If the user presses “Add”, the content will be add to “Web Apps” and the notification "Press option to ADD to APPS" will no longer appear.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.