Closed Bug 1244048 Opened 6 years ago Closed 6 years ago

[TV][2.5] Webapp is unable to be opened after adding from marketplace website

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: rickychien, Assigned: rickychien)

References

Details

(Whiteboard: [ft:conndevices][partner-blocker])

Attachments

(1 file)

STR:

In marketplace app:
1. Press option on an app's icon
2. Choose add to apps in dialog (then app will be installed)
3. After back from marketplace, we press on that app's icon again

Expect result:

app will be launched.

Actual result:

app wasn't launched.
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

Patching is coming~
Attachment #8713549 - Flags: review?(lchang)
Summary: [TV] Webapp is unable to be opened after adding from marketplace website → [TV][2.5] Webapp is unable to be opened after adding from marketplace website
blocking-b2g: --- → 2.5?
Flags: needinfo?(jocheng)
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

This patch doesn't seem to work. Please update it per our offline discussion. Thanks.
Attachment #8713549 - Flags: review?(lchang)
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(jocheng)
Whiteboard: [ft:conndevices][partner-blocker]
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

It works now!
Attachment #8713549 - Flags: review?(lchang)
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

Awesome work!
Attachment #8713549 - Flags: review?(lchang) → review+
Landed in master

https://github.com/mozilla-b2g/gaia/commit/69a51cf5c8f23ea1f03679d698989dafd2ac4541
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: Cannot launch hosted app in marketplace after it was installed
[Testing completed]: verified manually
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8713549 - Flags: approval-gaia-v2.5?
Comment on attachment 8713549 [details] [review]
[gaia] rickychien:cannot-open-webapp > mozilla-b2g:master

Approve for TV 2.5
Attachment #8713549 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
For uplifting to v2.5:

curl -L https://github.com/mozilla-b2g/gaia/commit/69a51cf5c8f23ea1f03679d698989dafd2ac4541.patch | git am
Flags: needinfo?(cbook)
Verify this issue on the latest build.
The installed app will be launched without error.

[Build Info]
Environment: Simulator 2.5.20160215231509
gaia:
https://github.com/mozilla-b2g/gaia/commit/71952d4b5417796380ddab274c5566a8eced2f8b
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/0b279b0579ae5656e3df34d522af06800e0a03bf
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.